summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-18 14:57:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-18 14:57:19 +0200
commit51c87724a8208bd891db27bb540f50a666297d35 (patch)
tree7dd277df245b2993c9be5a3e2450ac965736f70c
parentnet-misc/curl: remove older unstable version for CVE-2016-3739 (diff)
downloadgentoo-51c87724a8208bd891db27bb540f50a666297d35.tar.gz
gentoo-51c87724a8208bd891db27bb540f50a666297d35.tar.bz2
gentoo-51c87724a8208bd891db27bb540f50a666297d35.zip
dev-util/boost-build: Don't use python3 (bug #583406).
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-util/boost-build/boost-build-1.61.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/boost-build/boost-build-1.61.0.ebuild b/dev-util/boost-build/boost-build-1.61.0.ebuild
index 70502d4a7018..f0f588d713f7 100644
--- a/dev-util/boost-build/boost-build-1.61.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.61.0.ebuild
@@ -6,7 +6,7 @@ EAPI="6"
RESTRICT="test"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python2_7 )
inherit eutils flag-o-matic python-single-r1 toolchain-funcs versionator
MY_PV="$(replace_all_version_separators _)"
@@ -85,7 +85,7 @@ src_configure() {
# replace versions by user-selected one (TODO: fix this when slot-op
# deps are available to always match the best version available)
sed -i \
- -e "s|2.7 2.6 2.5 2.4 2.3 2.2|${EPYTHON#python}|" \
+ -e "s|27 26 25 24 23 22|${EPYTHON#python}|" \
engine/build.jam || die "sed failed"
fi
}