summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-10 20:54:05 +0000
committerSam James <sam@gentoo.org>2024-03-08 19:22:04 +0000
commit5223e983a0810e46633362ff4dbad6a194208819 (patch)
tree51c2b8c84dc478331648c1d26c7c29e8e0259d9a
parentsci-libs/rocSPARSE: lock dev-util/hip version, as with hip-6.0 build fails wi... (diff)
downloadgentoo-5223e983.tar.gz
gentoo-5223e983.tar.bz2
gentoo-5223e983.zip
dev-util/hip: install FindHIP.cmake: it contains hip_add_executable and other functions, required in rocTracer, pytorch, etc.
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/hip/hip-5.7.1-r2.ebuild (renamed from dev-util/hip/hip-5.7.1-r1.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-util/hip/hip-5.7.1-r1.ebuild b/dev-util/hip/hip-5.7.1-r2.ebuild
index 7b1a593f23e5..a2ec876aaf25 100644
--- a/dev-util/hip/hip-5.7.1-r1.ebuild
+++ b/dev-util/hip/hip-5.7.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,9 +60,10 @@ hip_test_wrapper() {
}
src_prepare() {
- # hipamd is itself built by cmake, and should never provide a
- # FindHIP.cmake module.
- rm -r "${WORKDIR}"/HIP-rocm-${PV}/cmake/FindHIP* || die
+ # Set HIP and HIP Clang paths directly, don't search using heuristics
+ sed -e "s:# Search for HIP installation:set(HIP_ROOT_DIR \"${EPREFIX}/usr\"):" \
+ -e "s:#Set HIP_CLANG_PATH:set(HIP_CLANG_PATH \"$(get_llvm_prefix -d ${LLVM_MAX_SLOT})/bin\"):" \
+ -i "${WORKDIR}"/HIP-rocm-${PV}/cmake/FindHIP.cmake || die
# https://github.com/ROCm-Developer-Tools/HIP/commit/405d029422ba8bb6be5a233d5eebedd2ad2e8bd3
# https://github.com/ROCm-Developer-Tools/clr/commit/ab6d34ae773f4d151e04170c0f4e46c1135ddf3e