summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-07-01 00:06:55 -0400
committerTim Harder <radhermit@gentoo.org>2018-07-01 00:16:16 -0400
commit5236d26f44a9c3b413bcd5636b02312cd7951729 (patch)
treea2243ed51cda7784fa66736a04e481b87efda820
parentsys-libs/libunwind: drop obsolete (diff)
downloadgentoo-5236d26f.tar.gz
gentoo-5236d26f.tar.bz2
gentoo-5236d26f.zip
dev-python/greenlet: version bump to 0.4.13
-rw-r--r--dev-python/greenlet/Manifest1
-rw-r--r--dev-python/greenlet/greenlet-0.4.13.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/greenlet/Manifest b/dev-python/greenlet/Manifest
index 21e2ef46fca2..8a77b1ad3298 100644
--- a/dev-python/greenlet/Manifest
+++ b/dev-python/greenlet/Manifest
@@ -1 +1,2 @@
DIST greenlet-0.4.12.tar.gz 57319 BLAKE2B 8260e495bb67e1a2b5b593d3513c3e2157a7b68b71fa3cb2a77de3b4ccc21b5d56bab26b6f0caf00cb669f051d22d7d6ad2700059a3d23b9ad7591f3d6608f43 SHA512 f3bf0f82b6e3bc687fc9b89469339cfb05e64518d1e49bc96066e8d47b8559f1c1aa53692cd25d839437a2f1b81df6fd9a4509a1b4063ec4ce1d97b73842e9f6
+DIST greenlet-0.4.13.tar.gz 58382 BLAKE2B a4afd9621ccd6444738c9b536af7ad5ceef5d3c8c4193ce637b4a8580c7070805419a917bef131f397286fae13f6e6f23409f5eedb814a41fcfee98356c0951a SHA512 625aaa8875b408442139191e1a63eca71c668675229907335f5caee623487aba5305c1d53b51e1764ad982b8edd07d04f984e08a75318a0a5672805667917a61
diff --git a/dev-python/greenlet/greenlet-0.4.13.ebuild b/dev-python/greenlet/greenlet-0.4.13.ebuild
new file mode 100644
index 000000000000..cc9bcb53e847
--- /dev/null
+++ b/dev-python/greenlet/greenlet-0.4.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Note: greenlet is built-in in pypy
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Lightweight in-process concurrent programming"
+HOMEPAGE="https://pypi.org/project/greenlet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~arm ~arm64 -hppa -ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}