summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-05 11:28:00 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-05 11:28:00 +0100
commit5248467c6990b4574b2bff82fa29d09364afdae2 (patch)
tree929de93134f0e196d17cf9c7f576313df2e64c00
parentx11-wm/fvwm: remove x86-fbsd (diff)
downloadgentoo-5248467c.tar.gz
gentoo-5248467c.tar.bz2
gentoo-5248467c.zip
dev-db/postgresql: remove elibc_NetBSD/elibc_OpenBSD
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-db/postgresql/postgresql-10.19.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-11.14.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-12.9.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-13.5.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-14.1.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-9.6.24.ebuild6
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild6
7 files changed, 7 insertions, 35 deletions
diff --git a/dev-db/postgresql/postgresql-10.19.ebuild b/dev-db/postgresql/postgresql-10.19.ebuild
index 8a3921037477..df3f68c9aec9 100644
--- a/dev-db/postgresql/postgresql-10.19.ebuild
+++ b/dev-db/postgresql/postgresql-10.19.ebuild
@@ -51,7 +51,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -66,7 +65,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -131,9 +130,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-11.14.ebuild b/dev-db/postgresql/postgresql-11.14.ebuild
index e0c2d013217f..0614243cb8c4 100644
--- a/dev-db/postgresql/postgresql-11.14.ebuild
+++ b/dev-db/postgresql/postgresql-11.14.ebuild
@@ -54,7 +54,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -69,7 +68,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -127,9 +126,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-12.9.ebuild b/dev-db/postgresql/postgresql-12.9.ebuild
index 1e4fa882aada..f3837a3f0404 100644
--- a/dev-db/postgresql/postgresql-12.9.ebuild
+++ b/dev-db/postgresql/postgresql-12.9.ebuild
@@ -54,7 +54,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -69,7 +68,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -127,9 +126,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-13.5.ebuild b/dev-db/postgresql/postgresql-13.5.ebuild
index 85510a53ff54..5f6ce9b239e3 100644
--- a/dev-db/postgresql/postgresql-13.5.ebuild
+++ b/dev-db/postgresql/postgresql-13.5.ebuild
@@ -54,7 +54,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -69,7 +68,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -129,9 +128,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-14.1.ebuild b/dev-db/postgresql/postgresql-14.1.ebuild
index a173e1e9ef7a..5dff65601bf4 100644
--- a/dev-db/postgresql/postgresql-14.1.ebuild
+++ b/dev-db/postgresql/postgresql-14.1.ebuild
@@ -55,7 +55,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -70,7 +69,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -128,9 +127,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-9.6.24.ebuild b/dev-db/postgresql/postgresql-9.6.24.ebuild
index 1073956aceb8..8310ab4b524f 100644
--- a/dev-db/postgresql/postgresql-9.6.24.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.24.ebuild
@@ -50,7 +50,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -65,7 +64,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -126,9 +125,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 049b5d38001e..c922ae2da90f 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -54,7 +54,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -69,7 +68,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -147,9 +146,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi