summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-07 06:01:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-07 06:43:01 +0200
commit5253f35ac85080e419dd1d72fdf77d0a920053fd (patch)
tree3dae9b7c82faf45f24bc64a130dce3bb46b952e0
parentdev-python/pywayland: Bump to 0.4.17 (diff)
downloadgentoo-5253f35ac85080e419dd1d72fdf77d0a920053fd.tar.gz
gentoo-5253f35ac85080e419dd1d72fdf77d0a920053fd.tar.bz2
gentoo-5253f35ac85080e419dd1d72fdf77d0a920053fd.zip
dev-python/pycares: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-4.4.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index feed9bf44da5..7e99012fc4b5 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-4.3.0.gh.tar.gz 44577 BLAKE2B b69eeb34a2f8c9d7025dc74881431b3fc5489b7f7e9142bb9ecdaf217e495ad72b1a6a7dc484a52e6a01394bbfa6d0609b2054dd4a663176cfb73d980642a3e1 SHA512 1dad1a6722bdd2bc59cc4ca774cc9da243e61a442ef383c238714b1274e90359352c72d16a2c1af2fcce3ea92708a7e5cee89a9b3eb7c015f9a194051c685f52
+DIST pycares-4.4.0.tar.gz 821630 BLAKE2B c2bddc54db9cd6ba92d7c4fb3809609a8a3526bab68e4cf48f0fee2e7473828f70ca696be11b904e9c3f9241de8b13568cd0317c8cb305a4aca7356f1b74cfb5 SHA512 db387f21975d015e0fcb01972ffb018476d51331a7a49bb4c0bf23ccfa13dff3f8b9c21d5f11da8ece3018debf36b1cddea032ef860353203cf38ab2b3d01e8a
diff --git a/dev-python/pycares/pycares-4.4.0.ebuild b/dev-python/pycares/pycares-4.4.0.ebuild
new file mode 100644
index 000000000000..64a4148b23ef
--- /dev/null
+++ b/dev-python/pycares/pycares-4.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # regression due to Internet changing (probably)
+ # https://github.com/saghul/pycares/issues/187
+ tests/test_all.py::DNSTest::test_query_class_chaos
+ # TODO
+ tests/test_all.py::DNSTest::test_custom_resolvconf
+)
+
+export PYCARES_USE_SYSTEM_LIB=1