summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-02 22:27:20 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-02 23:24:12 -0500
commit526c50e9cfdf957b8c82e68f037ef47e3fc497d3 (patch)
treeda7538e0c50ff6a5050d4c741422357ac1dd2abd
parentx11-libs/libfontenc: Version bump to 1.1.8 (diff)
downloadgentoo-526c50e9cfdf957b8c82e68f037ef47e3fc497d3.tar.gz
gentoo-526c50e9cfdf957b8c82e68f037ef47e3fc497d3.tar.bz2
gentoo-526c50e9cfdf957b8c82e68f037ef47e3fc497d3.zip
x11-libs/libxcb: Version bump to 1.16.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.16.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 6529081dae94..dc1d2bbb7b2c 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1 +1,2 @@
+DIST libxcb-1.16.1.tar.xz 455368 BLAKE2B 91d489eaf8b0bfb0c02a4d974f72871963dc86cdf60478d618636d580974b260ab822ab33c7174e05dc45adf01e53e423a7449550b7b43fabb3917f7d99219c0 SHA512 e3afdae1c0e2a5ae2add7b2c4fdd3283cb86023ef6448f5b8b29a4bb72c274e34eaf0fc7523762bcd3f5116910fe7374490e8f26c25744301563ced80acc3e7f
DIST libxcb-1.16.tar.xz 452964 BLAKE2B 1ddd5c2e6be8400a0a77db4b5fbd4698996fd1a00984e370b1f712f6b9ce456c8ccfb6992f2973f5eaf8d5b6b75f39b9f51a1458c2432ddb41edd8199b91b3f9 SHA512 002fbc126c6f09eb7db5e4197cd0572d495f64b6de714a76d9a024fe3e13122c1cfc7c55207c0dee76cc63fcccf87b37db513223eadaf760af2bd2a926443bf8
diff --git a/x11-libs/libxcb/libxcb-1.16.1.ebuild b/x11-libs/libxcb/libxcb-1.16.1.ebuild
new file mode 100644
index 000000000000..b006982c9472
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.16.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_MULTILIB=yes
+XORG_DOC=doc
+
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc selinux test +xkb"
+RESTRICT="!test? ( test )"
+SLOT="0/1.12"
+
+RDEPEND="
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ >=x11-base/xcb-proto-1.16.0
+ elibc_Darwin? ( dev-libs/libpthread-stubs )
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '>=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]')
+ doc? ( app-text/doxygen[dot] )
+ test? ( dev-libs/libxslt )
+"
+
+python_check_deps() {
+ python_has_version ">=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ )
+ xorg-3_src_configure
+}