summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-26 17:08:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-26 17:16:21 +0200
commit527ce8fd3ddd73aebaddf6726d2d2e2953bf234e (patch)
treeb4602ab3f9faca2025f08f52fe6327b8fccae968
parentdev-python/wsaccel: Enable py3.{7,8}, modernize (diff)
downloadgentoo-527ce8fd3ddd73aebaddf6726d2d2e2953bf234e.tar.gz
gentoo-527ce8fd3ddd73aebaddf6726d2d2e2953bf234e.tar.bz2
gentoo-527ce8fd3ddd73aebaddf6726d2d2e2953bf234e.zip
dev-python/www-authenticate: Enable py3.{7,8}, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/www-authenticate/www-authenticate-0.9.2.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild b/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
index d56aaf333fe8..c315ec4d2864 100644
--- a/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
+++ b/dev-python/www-authenticate/www-authenticate-0.9.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="WWW-Authenticate header parser"
@@ -13,14 +13,5 @@ SRC_URI="https://github.com/alexsdutton/www-authenticate/archive/${PV}.tar.gz ->
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- nosetests tests.py || die
-}
+distutils_enable_tests nose