summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-04-29 02:47:35 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-04-29 02:48:10 +0200
commit528a5f34096901dcf18d5e2d5747474a0536bc30 (patch)
tree6fe0d7fabc135099a69a31923e42b731d9a28dfd
parentdev-python/PyQt5: bump to 5.6.1 prerelease to fix build with USE=dbus (diff)
downloadgentoo-528a5f34096901dcf18d5e2d5747474a0536bc30.tar.gz
gentoo-528a5f34096901dcf18d5e2d5747474a0536bc30.tar.bz2
gentoo-528a5f34096901dcf18d5e2d5747474a0536bc30.zip
dev-python/PyQt5: remove broken 5.6
Gentoo-Bug: 581418 Package-Manager: portage-2.2.28
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.6.ebuild185
2 files changed, 0 insertions, 186 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index 3afebc49d9bb..155ff2d7c5d2 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1,3 +1,2 @@
DIST PyQt-gpl-5.5.1.tar.gz 3705749 SHA256 0a70ef94fbffcf674b0dde024aae2a2a7a3f5a8c42806109ff7df2c941bd8386 SHA512 ed9a4f30a50c0879f25b6a0841247f3f0de86942b55c1de9efea963bfbf64ee963a9e5c09be036ff2dec76164863b3b6235e45e8662776425f15378fa0abeab4 WHIRLPOOL 199a36ff1ee3689a76d0aae9d2bee586f9de3a0e3cf23c5b625c1f62b5f19311450afd9d009cbdb4f5be63ba024326c63ff0e6c9ea515216c686db9d8e07bcb3
DIST PyQt5_gpl-5.6.1.dev1604271126.tar.xz 2300884 SHA256 2a9ac535ac921bcd3678e33655bb3842a14f4cf6836eb29f32d0a62335ea061b SHA512 281d48cd8a875c454e970d6cecb0af2a2299f2ea6d062de599736d613c413dbab67072c80a80d490980eacf18bb35819b94255cd5891abbf6e291101bcd5b578 WHIRLPOOL e8255192a318529307b67992cdd12f9c9d4983099c1cece82761140bf3615fc36e1db52a9a795645c8ca93e21b801826802fd1b0fb3cf867c0f80d380a45c279
-DIST PyQt5_gpl-5.6.tar.gz 3720782 SHA256 2e481a6c4c41b96ed3b33449e5f9599987c63a5c8db93313bd57a6acbf20f0e1 SHA512 979537b35b7b6f7f63f702200db35453a9efe93565a0f0ea99d8092df4ca8c2a3d0fc10a5adcb499058e2340ed9141b3b38febf8049793beb471920c03645ee8 WHIRLPOOL ca7a023371005416e2846fd50be113ca72e9713b423b54f5d9c9bf75414a98f3f6c4ef69d913bf3c2f8783d684440e006feab85dea796354e931e80fa8a80ac4
diff --git a/dev-python/PyQt5/PyQt5-5.6.ebuild b/dev-python/PyQt5/PyQt5-5.6.ebuild
deleted file mode 100644
index a3dbd3edd91d..000000000000
--- a/dev-python/PyQt5/PyQt5-5.6.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit multibuild python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="http://www.riverbankcomputing.com/software/pyqt/intro
- https://pypi.python.org/pypi/PyQt5"
-
-MY_P=${PN}_gpl-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
-else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-# TODO: QtBluetooth, QtLocation, QtNfc, QtWebEngine{Core,Widgets}
-IUSE="dbus debug declarative designer doc examples gles2 gui help multimedia
- network opengl positioning printsupport sensors serialport sql svg
- testlib webchannel webkit websockets widgets x11extras xmlpatterns"
-
-# The requirements below were extracted from configure.py
-# and from the output of 'grep -r "%Import " "${S}"/sip'
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- declarative? ( gui network )
- designer? ( widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui widgets )
- positioning? ( gui )
- printsupport? ( widgets )
- sensors? ( gui )
- serialport? ( gui )
- sql? ( widgets )
- svg? ( gui widgets )
- testlib? ( widgets )
- webchannel? ( network )
- webkit? ( gui network printsupport widgets )
- websockets? ( network )
- widgets? ( gui )
- xmlpatterns? ( network )
-"
-
-# Minimal supported version of Qt.
-QT_PV="5.4.2:5"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.18:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV}[printsupport] )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( "${S}"/{ChangeLog,NEWS} )
-
-pyqt_use_enable() {
- use "$1" || return
-
- if [[ $# -eq 1 ]]; then
- echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
- else
- shift
- echo ${@/#/--enable=}
- fi
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- $(usex debug '--debug --trace' '')
- --verbose
- --confirm-license
- --qmake="$(qt5_get_bindir)"/qmake
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --sip-incdir="$(python_get_includedir)"
- --qsci-api
- --enable=QtCore
- --enable=QtXml
- $(pyqt_use_enable dbus QtDBus)
- $(usex dbus '' --no-python-dbus)
- $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
- $(usex declarative '' --no-qml-plugin)
- $(pyqt_use_enable designer)
- $(usex designer '' --no-designer-plugin)
- $(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
- $(pyqt_use_enable help)
- $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
- $(pyqt_use_enable network)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable positioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable sensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable sql)
- $(pyqt_use_enable svg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets)
- $(pyqt_use_enable x11extras QtX11Extras)
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- local tmp_root=${D%/}/tmp
- emake INSTALL_ROOT="${tmp_root}" install
-
- local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
-
- python_doexe "${tmp_root}${EPREFIX}"/usr/bin/pyuic5
- rm "${tmp_root}${EPREFIX}"/usr/bin/pyuic5 || die
-
- multibuild_merge_root "${tmp_root}" "${D}"
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
- use doc && dodoc -r doc/html
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}