summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-04 22:48:13 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-04 22:48:30 +0300
commit529caf2f168704259b67140b249e27c8d9972c49 (patch)
treeef4a7ee28b0f6512d5fe9864395898bd27a67010
parentmedia-plugins/frei0r-plugins: Drop old (diff)
downloadgentoo-529caf2f.tar.gz
gentoo-529caf2f.tar.bz2
gentoo-529caf2f.zip
dev-libs/libinput: Version bump (v1.12.1)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.12.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 23a5becb0df3..4fedfac7c75f 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,4 @@
DIST libinput-1.10.7.tar.xz 494648 BLAKE2B ddcbe5f54b90f8291c16e5912fa3d673fb2c66f0247c9d771f7c2dfeeef9b51404f31d7ac99cfd20b37e1d01d6b2b3bc95155ab6581c6a94e922e153d9098892 SHA512 b102b8065ceed7511ad26efba34d5d9b0c13f0f7aaa882bb21501f7a5166f4cbe140fcbb488e90e6880bd47bb2b27667a4d6aa79b8726269fa1337897034a684
DIST libinput-1.11.3.tar.xz 487408 BLAKE2B 38dc14cf018ca59279e8b6e85fd91f4b29545b4a55ab968cb11d9a8afc8d80c311efc6e57339b9baa9fb270f52cfb0758ff8ea313991867c35f3da47910977ac SHA512 5e18daab6202bcbfddeebc35dac4cabb5f726b5b73f5fc87975b58f3019a54a4b1f506a3200e920638ddddfb978a0b96c23c2e90b081942f86d33c16d4836949
DIST libinput-1.12.0.tar.xz 519320 BLAKE2B b40036740350180ca0e183088651647e3604bca236ab27c99a941934b27ed67a21d8596be9baab68dd798dea9c5967cca3a038623ba2870dc2ad3db8336e0b96 SHA512 4aee877785f9ac080e4f8ee20f3643bc4f3ddbc568aca6c363a962f8c8f76b8db7dc113c8167092f0277d112346a85b9a7e7c3c3f227ed243aaba32c9092c924
+DIST libinput-1.12.1.tar.xz 520072 BLAKE2B 2d2b2d82f27ac01ff25b3bf6fd7b77ca56467ab818cdc5d4a641629fed623ef5042915889f54f71b1881595af1d85770bbf4ecfd798c079878efa0a0546c4a36 SHA512 de1714526ee1244e3086729efa5b72724b2b989fa8d04418e633d1ef5a8ea777ae3cd4b8c5b015ca0da2b8cf5b07111bff2283c7d6068abcdfa81c3f71b81d68
diff --git a/dev-libs/libinput/libinput-1.12.1.ebuild b/dev-libs/libinput/libinput-1.12.1.ebuild
new file mode 100644
index 000000000000..e4f4f74efb75
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ -Dtests=false # tests are restricted
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+}
+
+pkg_postinst() {
+ udevadm hwdb --update --root="${ROOT%/}"
+}