summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-10-03 23:24:18 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-10-03 23:38:51 +0200
commit529e398d4e699a066617923f34b5e548b04f64a2 (patch)
tree47b63295ee6c6a5115df0e2e03c67dc8e8a05b41
parentsys-kernel/linux-headers: EAPI=6: use eapply (didnt find epatch before!) (diff)
downloadgentoo-529e398d.tar.gz
gentoo-529e398d.tar.bz2
gentoo-529e398d.zip
dev-python/flask-appconfig: add Python 3.7 support, missing doc dep
Also make tests verbose. Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
index 2e1c7689325f..85f4e59c812c 100644
--- a/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
+++ b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -24,7 +24,10 @@ RDEPEND="
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
@@ -46,5 +49,5 @@ python_compile_all() {
}
python_test() {
- py.test || die "Tests failed with ${EPYTHON}"
+ pytest -vv || die "Tests failed with ${EPYTHON}"
}