summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-11-12 16:52:36 -0500
committerCraig Andrews <candrews@gentoo.org>2023-11-12 17:25:11 -0500
commit52addc96428db9592f7ac78b765d6a095e16eea1 (patch)
tree50691dca729f2ca7a8517b4b224b58af19f08fc5
parentdev-python/click-help-colors: Bump to 0.9.3 (diff)
downloadgentoo-52addc96.tar.gz
gentoo-52addc96.tar.bz2
gentoo-52addc96.zip
net-p2p/cpuminer-opt: add 23.8
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-23.8.ebuild48
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild5
3 files changed, 51 insertions, 3 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 08384e8652a5..0967b245445d 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
+DIST cpuminer-opt-23.8.tar.gz 1789910 BLAKE2B 944cf64457b9eb37726e1d0f0976dbb61a67a8690803e0f5b1914770cdcfba760fa554f389f3a4da97256b57c2b76ae5516b8b2d864d09667aeeaa7ec9af8825 SHA512 dc1a9f635f7aa9b751f6f9a070e2665cecb95d0f859b0cdf77b2b5ba906724a567d00fb5d9542b063e381c3bcf1840997bf37534bde59fb667d9b2002fa0d67b
DIST cpuminer-opt-3.23.1.tar.gz 1838750 BLAKE2B 9088f4413c4e15db185da5ee6ee210ece79a9d802d0c07045a3a402994ae5d596c9aa88dc7a7f2f99f731d7f126a62e8182ba0b41c8d120602413c95c7faba23 SHA512 c30f20a40e3c3151ce513e91f3a893cadc00b108f36d8c23d528d844a0eb0f1968d8558f4a060748306d85e0960dc633efedd010349ad0c98bc62c449214850d
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-23.8.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-23.8.ebuild
new file mode 100644
index 000000000000..7a6224bf33d8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-23.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ newins config-template.json cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index ae5b2d66fa4b..7a6224bf33d8 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,6 @@ DEPEND="
dev-libs/gmp:=
dev-libs/jansson:=
>=net-misc/curl-7.15[ssl]
- dev-libs/openssl:0=
"
RDEPEND="${DEPEND}"
if [[ ${PV} == "9999" ]] ; then
@@ -41,7 +40,7 @@ src_install() {
default
systemd_dounit "${FILESDIR}"/${PN}.service
insinto "/etc/${PN}"
- doins cpuminer-conf.json
+ newins config-template.json cpuminer-conf.json
}
src_test() {