summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-12 06:37:16 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-12 16:23:44 -0500
commit52b42adeafae37f4a3b5dbb825435826384a5d68 (patch)
tree0686e4e966b66cfe874525a50a57e78015253146
parentdev-qt/qt-docs: drop 6.6.0_p202310040911 (diff)
downloadgentoo-52b42adeafae37f4a3b5dbb825435826384a5d68.tar.gz
gentoo-52b42adeafae37f4a3b5dbb825435826384a5d68.tar.bz2
gentoo-52b42adeafae37f4a3b5dbb825435826384a5d68.zip
dev-qt/qttools: update live
Build system now checks for minimum clang version, and we still have the unusable clang:14 in-tree. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index 8966bdc9123b..c171114332af 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -31,11 +31,15 @@ REQUIRED_USE="
# and 3rdparty/ tries to FetchContent gtest)
RESTRICT="test"
-LLVM_MAX_SLOT=17
+QTTOOLS_LLVM_SLOTS=({17..15}) # QDOC_MINIMUM_CLANG_VERSION
+LLVM_MAX_SLOT=${QTTOOLS_LLVM_SLOTS[0]}
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,widgets?]
assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? ( <sys-devel/clang-$((LLVM_MAX_SLOT+1)):= )
+ clang? (
+ <sys-devel/clang-$((LLVM_MAX_SLOT+1)):=
+ || ( $(printf "sys-devel/clang:%d " "${QTTOOLS_LLVM_SLOTS[@]}") )
+ )
designer? (
~dev-qt/qtbase-${PV}:6[xml,zstd=]
zstd? ( app-arch/zstd:= )