summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 09:45:10 +0100
committerSam James <sam@gentoo.org>2021-10-14 09:45:10 +0100
commit52bf332627f850a84d09d6ccd96c7a968b0efaed (patch)
tree802ffc1f201c0054ab85648e067487b441a9d3ca
parentsys-libs/readline: avoid underlinking libreadline in prefix bootstrap (diff)
downloadgentoo-52bf3326.tar.gz
gentoo-52bf3326.tar.bz2
gentoo-52bf3326.zip
app-shells/bash: add EPREFIX to rpath
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.1_p8.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-shells/bash/bash-5.1_p8.ebuild b/app-shells/bash/bash-5.1_p8.ebuild
index 88199a177aa1..5f26b4a7e3ab 100644
--- a/app-shells/bash/bash-5.1_p8.ebuild
+++ b/app-shells/bash/bash-5.1_p8.ebuild
@@ -159,7 +159,7 @@ src_configure() {
fi
if use plugins ; then
- append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.