summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2022-02-11 01:14:34 +0100
committerJonas Stein <jstein@gentoo.org>2022-02-11 01:14:55 +0100
commit52c2f8b518e651417029a6a26835dff02aa4a328 (patch)
tree7cf132285c5232d10f5110be15662b3686f951d1
parentdev-python/django-js-asset: Remove old (diff)
downloadgentoo-52c2f8b518e651417029a6a26835dff02aa4a328.tar.gz
gentoo-52c2f8b518e651417029a6a26835dff02aa4a328.tar.bz2
gentoo-52c2f8b518e651417029a6a26835dff02aa4a328.zip
sys-boot/unetbootin: bump to 702
Version bump to 702 and EAPI=8 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
-rw-r--r--sys-boot/unetbootin/Manifest1
-rw-r--r--sys-boot/unetbootin/unetbootin-702.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index fd507164f4dd..cc43b7a722c9 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1 +1,2 @@
DIST unetbootin-700.tar.gz 16694955 BLAKE2B d8c00b56c5ae2daac696b62ef207c62dc91f67699c8823e2a751eff536d03fd0a50a931e9a4598b05d99be968b7e895ab521f605b4e0080d591a34c9e67f685e SHA512 0d1b23dddf0e0e3eca81f8ef07fe375f0867ee3fa631c3a3cfe33a846b8d704b36e0efe4c947d7c68e5c1bff370ba87c34aa52c5bf8fc414cd89777f9f1858b7
+DIST unetbootin-702.tar.gz 16694922 BLAKE2B 4205b8e5a64ecbd95e3b5f3492a01333691768547e6dbe5f954982dfa35d0794bbf8b4bc7002ff62b13675e9beaa25caf83d999489c9fabd36acc8df171e5d05 SHA512 4794a1c5481a082ab589c213156501697a9c2262102e1d0ca882a6c757d388d0ca768ed9acff29aac89f17a4842a93ab25ecbfceaafa27ea91d578e16fabe153
diff --git a/sys-boot/unetbootin/unetbootin-702.ebuild b/sys-boot/unetbootin/unetbootin-702.ebuild
new file mode 100644
index 000000000000..d42e3c699212
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-702.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic qmake-utils xdg-utils toolchain-funcs
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="https://github.com/unetbootin/unetbootin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-675-desktop.patch )
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ export QMAKE_CXX="$(tc-getCXX)"
+
+ "$(qt5_get_bindir)/"lrelease ${PN}.pro || die
+
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}