summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-10-18 19:37:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-10-18 19:39:26 +0300
commit52cc74d381d9f73203673290b1d36c73a11ed666 (patch)
tree4126176c8e76159c1be8efc0fabb77e82def178f
parentapp-admin/syslog-ng: depend on dev-libs/libpcre2 instead of dev-libs/libpcre (diff)
downloadgentoo-52cc74d381d9f73203673290b1d36c73a11ed666.tar.gz
gentoo-52cc74d381d9f73203673290b1d36c73a11ed666.tar.bz2
gentoo-52cc74d381d9f73203673290b1d36c73a11ed666.zip
dev-libs/raft: add 0.18.1
- switch upstream away from Canonical. This is a 100 % compatible change for now at least, but our main focus will be incus in the long run so it makes sense to follow the community-maintained libraries as well. See bgo#915960 for details. Closes: https://bugs.gentoo.org/915960 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/metadata.xml2
-rw-r--r--dev-libs/raft/raft-0.18.1.ebuild55
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index fc9b6fd7c5b3..f40d74a80036 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1,2 +1,3 @@
DIST raft-0.17.1.tar.gz 354331 BLAKE2B d1be3eb4139422dab8126879d2ba0782e8635a60ce9752f4389f79dd2238021d9679d3b5f799c9627921c954a4395cdff139ff41f8145ebc43190f2c4aa3e5a7 SHA512 20e2b4a144a597b77bcb31e8b22355725142b14fb50e20b33509e7b0dd10aa20d08501b66e836c659e9aa492184db71ea9e53a45fe4b908b1464eb94431154db
DIST raft-0.18.0.tar.gz 365558 BLAKE2B 57fc8c144a45eb101f53c8dd3a1eb896c733b7c5c369300852bea1474b8178b46c943c29e81107758bfa527d8fc1a9c80c4ca1bfc599dfc5ace090a18c693f11 SHA512 c6ab125a4841c5241310ea9785bb6ae3860c0a2ff39487499c2caa0b387729f7f7e54fa0de3aad3a99bdf5ec7d4a12c68a69244c6d8b8dcdf846c1cdfeb11b3b
+DIST raft-0.18.1.tar.gz 334308 BLAKE2B 6518914435129573fe03368bb653b42bb6424cfe6d96ea47164bb77c62ab229dcc977c59ad8004d269d7a44fdfec3a852b4dc0309129ccff7fcfc1fe425806f9 SHA512 73f8a7eb4d38e02ec888bc1062a8b8c419b17f87a09d9bdffac5c015077a42c28d92c285571a5c49d2a1d8ddd6b972469a7baa0f19a839faf6c17a02968f805a
diff --git a/dev-libs/raft/metadata.xml b/dev-libs/raft/metadata.xml
index fc7c392c0349..94076382bb1e 100644
--- a/dev-libs/raft/metadata.xml
+++ b/dev-libs/raft/metadata.xml
@@ -20,6 +20,6 @@
snapshots).
</longdescription>
<upstream>
- <remote-id type="github">canonical/raft</remote-id>
+ <remote-id type="github">cowsql/raft</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-libs/raft/raft-0.18.1.ebuild b/dev-libs/raft/raft-0.18.1.ebuild
new file mode 100644
index 000000000000..d6bad82ee93e
--- /dev/null
+++ b/dev-libs/raft/raft-0.18.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}