summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-03-29 11:57:22 -0400
committerRichard Freeman <rich0@gentoo.org>2020-03-29 11:57:22 -0400
commit52dd3be236544b98820219bab687f6678c3ceed6 (patch)
treedb1e3b270a557f12451bfe60ab8acd47cf3e1a44
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-52dd3be236544b98820219bab687f6678c3ceed6.tar.gz
gentoo-52dd3be236544b98820219bab687f6678c3ceed6.tar.bz2
gentoo-52dd3be236544b98820219bab687f6678c3ceed6.zip
app-backup/duplicity: bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Richard Freeman <rich0@gentoo.org>
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.12.1612.ebuild50
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs.patch21
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 315d66b58625..496cf40ae179 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,2 +1,3 @@
DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
DIST duplicity-0.8.11.1596.tar.gz 1872223 BLAKE2B ad3ee2536731d1a6e8fb3fd87bb69b8ce8b43bb90688fe957cfb2718ad44f57db98c3aec4805356a7d44bea681f6ec9603aa082dbf86e58684fbe8000d1676b5 SHA512 67940d73d8213559ba88ec21e1326aca0dd065888cbf2e3c68f0f515ba9246100fd6e6d0bd1f12cb678702559f2266b7905931506d2ff6fe6fd35c673593479b
+DIST duplicity-0.8.12.1612.tar.gz 1883596 BLAKE2B 6d3075cdc6cd1f09e60cdbdc5d17867f3686a7e05ce16b908b797b6d2c343ae4c8104793b9f389920112917089086ac8f4c5baffa326c528c023bd40daab8643 SHA512 eac4d1aecd604ece123bd3b5cecd3b65e1213c243db1a3ce25bae58360d666dd1db07ba0a137e7682f99775ece20453c7dc44cd87940b56c0acd05d01149c951
diff --git a/app-backup/duplicity/duplicity-0.8.12.1612.ebuild b/app-backup/duplicity/duplicity-0.8.12.1612.ebuild
new file mode 100644
index 000000000000..3f789257f08d
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.12.1612.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs.patch b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs.patch
new file mode 100644
index 000000000000..6b8c710f3160
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.12.1612-fix-docs.patch
@@ -0,0 +1,21 @@
+--- duplicity-0.8.11.1596/setup.py 2020-03-05 09:18:42.532941503 -0500
++++ duplicity-0.8.11.1596/setup.py 2020-03-05 09:20:10.612061492 -0500
+@@ -88,18 +88,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % version_string,
+- [
+- u'AUTHORS',
+- u'CHANGELOG',
+- u'Changelog.GNU',
+- u'COPYING',
+- u'README',
+- u'README-LOG',
+- u'README-REPO',
+- u'README-TESTING',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':