summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-31 10:09:59 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-04-29 11:45:19 +0300
commit52e1c0009631818fa409ab9119d9c2023253cb60 (patch)
tree11768af4339556f4ba51cab2b36ad58749b226bc
parentgames-emulation/gambatte-jg: use src_configure (diff)
downloadgentoo-52e1c0009631818fa409ab9119d9c2023253cb60.tar.gz
gentoo-52e1c0009631818fa409ab9119d9c2023253cb60.tar.bz2
gentoo-52e1c0009631818fa409ab9119d9c2023253cb60.zip
games-emulation/gambatte-jg: add 0.6.0
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--games-emulation/gambatte-jg/Manifest1
-rw-r--r--games-emulation/gambatte-jg/gambatte-jg-0.6.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/gambatte-jg/Manifest b/games-emulation/gambatte-jg/Manifest
index 40a95ee7206c..d220eb85ea9a 100644
--- a/games-emulation/gambatte-jg/Manifest
+++ b/games-emulation/gambatte-jg/Manifest
@@ -1 +1,2 @@
DIST gambatte-0.5.1.tar.bz2 305331 BLAKE2B edde374d0ed2b5f8c9ca3060520f2ffa392a82378fcac0ad18ea6ca0a02bc5240c8dc9f72c6427f2c85f11fd4b68b1a92717c20f34ad71d27a1ee3e9eb5238cd SHA512 60ea7199b1f26bb403ac48d871ef5191cbd6de6794ecde72693d9360ca476b364dc9e6c5bd88d5e54e9835d67feb17d1b7453b48096736ef870bea473b0691a5
+DIST gambatte-0.6.0.tar.bz2 384803 BLAKE2B 8d203385704fc212c84835ec1446dac9b7e64b59dc04ffc72533fe309716ea78a58d5b61707214b2b66dd9af5e5f9d52e0e46973673ab50b04dbd3b2075de51f SHA512 538a52d91b554c9a01c8e4ffbb96aa81638344687d0dee593f8950c10a93d732f44442ada4809cb36be5311df2bdce65b1d5f71db97579bcf8cb9516dddc30a3
diff --git a/games-emulation/gambatte-jg/gambatte-jg-0.6.0.ebuild b/games-emulation/gambatte-jg/gambatte-jg-0.6.0.ebuild
new file mode 100644
index 000000000000..5b5647ac0425
--- /dev/null
+++ b/games-emulation/gambatte-jg/gambatte-jg-0.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Gambatte"
+HOMEPAGE="https://gitlab.com/jgemu/gambatte"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="
+ GPL-2
+ examples? ( 0BSD )
+ jgmodule? ( BSD )
+"
+SLOT="1"
+IUSE="examples +jgmodule shared"
+REQUIRED_USE="|| ( examples jgmodule shared )"
+
+DEPEND="
+ examples? (
+ media-libs/libsdl2[sound,video]
+ media-libs/speexdsp
+ )
+ jgmodule? (
+ media-libs/jg:1=
+ media-libs/soxr
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ jgmodule? ( games-emulation/jgrf )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local makeopts=(
+ DISABLE_MODULE=$(usex jgmodule 0 1)
+ ENABLE_EXAMPLE=$(usex examples 1 0)
+ ENABLE_SHARED=$(usex shared 1 0)
+ )
+ export MY_MAKEOPTS="${makeopts[@]}"
+}
+
+src_compile() {
+ local mymakeargs=(
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ ${MY_MAKEOPTS}
+ )
+ emake "${mymakeargs[@]}"
+}
+
+src_install() {
+ local mymakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ ${MY_MAKEOPTS}
+ )
+ emake install "${mymakeargs[@]}"
+}