summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 12:43:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 14:18:19 +0100
commit52f3bca7ec171669196d1ff7caf037f4ad1c1be5 (patch)
treea327aabe3680aab4fb1610813ee7e603346535c9
parentdev-python/openapi-spec-validator: Bump to 0.5.3 (diff)
downloadgentoo-52f3bca7.tar.gz
gentoo-52f3bca7.tar.bz2
gentoo-52f3bca7.zip
dev-python/pyglet: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 63fb7ed6f621..87193dea8c3d 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,3 +1,4 @@
DIST pyglet-1.5.27.gh.tar.gz 6532179 BLAKE2B f1dc668530a69e275860befe11f4c86003c5de2dadede706df7abac9eb6fb1729ea030c7053f0149926f3ffdd12985d9abea4afac65de3b6b7541fe871eda369 SHA512 98896dab06873cbf3cdd0d4015cb0b9e062cffb1110908bd422ecdc4f0e16943adc8a4986e7dbfdae4392e82ac115bad6f937896e166989ad2c4d73a0f45c8be
DIST pyglet-2.0.2.1.gh.tar.gz 6206090 BLAKE2B e671e1800f8f9e80ff301692973e6085c63b751944d221added744edf3910dd13c15f741637b23f04777b64bfe2865698410be1859009bc1455cf51458e8916a SHA512 4b6d4883025b55d7e1515c65c0b18a5b24d152a5e7f547379329388046c2f1818f9e203d2913825a1156eb3271100b6257f334310959c2e7a1b4ba2b61f2d398
DIST pyglet-2.0.3.gh.tar.gz 6213542 BLAKE2B 7a47df69761d718e6b1a700105ca7e75b650109d37bea340cae147885ea2158da9af45c9c5733cd6cdc41e17800471921457dda281285e4c6836191200a92be2 SHA512 7617c34dfc65d8a957e6e4093c467d2debcd36e053ef0e1b350cc63fa886e59a6e8cfa0bbbc9db163c736f5ec975c0a105f7ccb0c8bb193744b692d550e0f757
+DIST pyglet-2.0.4.gh.tar.gz 6172461 BLAKE2B aa52844336b2fa34c6d75c8ee45070b7d8b85c283e374daeffa21367d6ddefaf39c22258eb00c666dad1f5ee8d157c0b1716a5cd1329942e98538e8172ed6137 SHA512 c26c59b9f7e6f2b1bd20456917ed50d6b70169dd2af5b92cc61d0e0515dc7c989eba9b41e00a106510d53e8ea218cde185f8b5038428490f3b9b3623a2f40207
diff --git a/dev-python/pyglet/pyglet-2.0.4.ebuild b/dev-python/pyglet/pyglet-2.0.4.ebuild
new file mode 100644
index 000000000000..0a8fe221c50a
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to system load
+ tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken test
+ # https://github.com/pyglet/pyglet/issues/606
+ tests/unit/test_events.py::test_push_handlers_instance
+ )
+ fi
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}