summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-25 23:04:45 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-25 23:04:45 +0200
commit52faecfab023afea340cb5a35770f0dcdaf952e6 (patch)
tree36565895d506ca785b179542b8405e9018e5f99f
parentnet-misc/modemmanager: Version bump to 1.18.10 (diff)
downloadgentoo-52faecfab023afea340cb5a35770f0dcdaf952e6.tar.gz
gentoo-52faecfab023afea340cb5a35770f0dcdaf952e6.tar.bz2
gentoo-52faecfab023afea340cb5a35770f0dcdaf952e6.zip
sys-cluster/rdma-core: add 41.0
Bug: https://bugs.gentoo.org/778971 Bug: https://bugs.gentoo.org/792033 Bug: https://bugs.gentoo.org/835411 Bug: https://bugs.gentoo.org/837830 Bug: https://bugs.gentoo.org/852083 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/Manifest1
-rw-r--r--sys-cluster/rdma-core/rdma-core-41.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
index 6d54badbb34f..64abd5527599 100644
--- a/sys-cluster/rdma-core/Manifest
+++ b/sys-cluster/rdma-core/Manifest
@@ -1,2 +1,3 @@
DIST rdma-core-38.0.tar.gz 1760189 BLAKE2B ab028ce9367353201748f19d05d4d02170920b155b7ebb3584043729422e377cfb4ae29ed442ce7f965faa2470fe558499e9b2e7da51f282fa65ab029d4bcaa9 SHA512 98b3e3d26675891d54652817851f172855443faf6950b5c17177f10f5b3b197778590ad0e9640ecceaba17cf4aceb276ddb145ab46c1f6af9d2f6954688c3239
DIST rdma-core-39.0.tar.gz 1762652 BLAKE2B 7fed2be57624451c660120c6360fedd15ffaff36608879a329c3f078b647cb325c94fc949ef14f99b3be8b43ffddee6759e7da2f88287adf4dee413658afb5db SHA512 a003cae24cff6791a6281b1ab7cc1823fb08a74e03231bf846f8ebbd5fa447c8dd900357493108f6a2b22fd5dabd657fe42e1ce2f65a01746ce47a3222815459
+DIST rdma-core-41.0.tar.gz 1784540 BLAKE2B 3c153dcc3563427f32fa32d9a31527635c6bb3e63297c201f30de1328a68ac73ecb3af89074dfcc27d92c640d14d8d8ec61c001659d18336a4156cf8ed22996c SHA512 d8c1210ca078ea53879cee42c838cc88bcc98430471ae609d8c4a25218dbfd63a70f5bbd4e9ba6efabdfc467f7d5796ce618ec22013d414f17502d1257601a80
diff --git a/sys-cluster/rdma-core/rdma-core-41.0.ebuild b/sys-cluster/rdma-core/rdma-core-41.0.ebuild
new file mode 100644
index 000000000000..d3914a582bc8
--- /dev/null
+++ b/sys-cluster/rdma-core/rdma-core-41.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-single-r1 udev systemd
+
+DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
+HOMEPAGE="https://github.com/linux-rdma/rdma-core"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
+else
+ SRC_URI="https://github.com/linux-rdma/rdma-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
+SLOT="0"
+IUSE="neigh python static-libs systemd valgrind"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ dev-lang/perl
+ virtual/libudev:=
+ neigh? ( dev-libs/libnl:3 )
+ systemd? ( sys-apps/systemd:= )
+ valgrind? ( dev-util/valgrind )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${COMMON_DEPEND}
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )"
+RDEPEND="${COMMON_DEPEND}
+ !sys-fabric/infiniband-diags
+ !sys-fabric/libibverbs
+ !sys-fabric/librdmacm
+ !sys-fabric/libibumad
+ !sys-fabric/ibacm
+ !sys-fabric/libibmad
+ !sys-fabric/srptools
+ !sys-fabric/infinipath-psm
+ !sys-fabric/libcxgb3
+ !sys-fabric/libcxgb4
+ !sys-fabric/libmthca
+ !sys-fabric/libmlx4
+ !sys-fabric/libmlx5
+ !sys-fabric/libocrdma
+ !sys-fabric/libnes"
+# python is required unconditionally at build-time
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_RUNDIR=/run
+ -DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
+ -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"
+ -DENABLE_VALGRIND="$(usex valgrind)"
+ -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
+ -DENABLE_STATIC="$(usex static-libs)"
+ -DNO_PYVERBS="$(usex !python)"
+ -DNO_MAN_PAGES=1
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ udev_dorules "${ED}"/etc/udev/rules.d/70-persistent-ipoib.rules
+ rm -r "${ED}"/etc/{udev,init.d} || die
+
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ newinitd "${FILESDIR}"/iwpmd.init iwpmd
+ fi
+
+ newinitd "${FILESDIR}"/srpd.init srpd
+
+ use python && python_optimize
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}