summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-01 07:37:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-01 08:13:07 +0200
commit53085b91c21da9e4fdd27f08262cd936b5cdfbb1 (patch)
tree671796e0cc07ed974fd47fad3b8f5c4dee8375d0
parentxfce-extra/thunar-archive-plugin: Bump to 0.5.1 (diff)
downloadgentoo-53085b91.tar.gz
gentoo-53085b91.tar.bz2
gentoo-53085b91.zip
dev-python/pyfakefs: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 1b2f69f8862b..b2dd7fa21064 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.1.0.gh.tar.gz 212507 BLAKE2B b9607ff2af71d6697bb5ea5ceae0bb1b92b9aa2e91bafdf24d3dab6f5412a6fd8ff590983085079e9a7b1569b839f4fc5b443d5904decf2de5511ab856e8de7d SHA512 40d4e3fb422c2d9515c00bfa9940a8799d5e102a5775ac34d45e99286759451d1287df1e32f45956a84c1052cc02eed98a8f9789a628ac253771042b011ddd3e
+DIST pyfakefs-5.2.0.gh.tar.gz 218488 BLAKE2B b0d2fc01e6fc4b965d5b1099700864c309cb3531b4672fe86db7e1517e4661b64b268f3551eabdd6a20ce2c9b3c4b109bce050962ca7deec6450825292468677 SHA512 d1d7557f5bcf4ae5917f71d74ee942c428f39c9c1bca5cd31e6f7662084a0db044bddaa0e6e95ea7ee410444b46e3cae91f8dbf74050225f94ecd6436a4c5468
diff --git a/dev-python/pyfakefs/pyfakefs-5.2.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.2.0.ebuild
new file mode 100644
index 000000000000..876026d4079f
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}