summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-04 21:58:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-05 22:27:34 +0100
commit5317fc865771edba8533c72494dfa2f6f3cd1a37 (patch)
tree6e865ec27c3ea64fb2b8f06f1852c69695c3b49a
parentdev-python/flask-gravatar: python3_8 (diff)
downloadgentoo-5317fc86.tar.gz
gentoo-5317fc86.tar.bz2
gentoo-5317fc86.zip
dev-python/semantic_version: 2.8.4 version bump, python3_8
Tests passed. Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/semantic_version/Manifest1
-rw-r--r--dev-python/semantic_version/semantic_version-2.8.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/semantic_version/Manifest b/dev-python/semantic_version/Manifest
index 073d02691b2d..610a9ed5b05d 100644
--- a/dev-python/semantic_version/Manifest
+++ b/dev-python/semantic_version/Manifest
@@ -1 +1,2 @@
DIST semantic_version-2.8.2.tar.gz 49243 BLAKE2B 73c66696b2fd6e30dc74bba6f1d4d84d71bf470f8ecd2ab93b4225f573bb0575f797b573d8fa6605ff35636de713a8f69522a2719949cf0bfebd0791ab5bae99 SHA512 f54ad2bb2e8392e154718c3dff8e7a7fa7663d7df0ab4b196444e0ad22440fe9d9a3abe9043824c0e0121f9051121b8c9d67f76a615aa5348c321e217b3a5dcd
+DIST semantic_version-2.8.4.tar.gz 49774 BLAKE2B 30dc1bbca9e24db993e2c9eae2ba05e7a102ba8baae10bc49640d74a3fe9ff943b7606b7c7cbad3d7b25d65a10df7ab587179b5a9bfe73822eb62b945074db23 SHA512 2ed9a8ae03384731865c0b160a9bc92f9c877b610a4ecf15c30969886f15e7cdf77cf384997f96126a8a77534e032c70f587c835fe288fe4ab3e9e2061cb6f47
diff --git a/dev-python/semantic_version/semantic_version-2.8.4.ebuild b/dev-python/semantic_version/semantic_version-2.8.4.ebuild
new file mode 100644
index 000000000000..a390c08f6552
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="https://pypi.org/project/semantic_version/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RESTRICT="!test? ( test )"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # The django test hangs
+ pytest -vv --ignore tests/test_django.py\
+ || die "tests failed with ${EPYTHON}"
+}