summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-27 11:23:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-27 11:30:20 +0200
commit531b96fb745d5474c3f0b87668f5c8526baf6922 (patch)
tree80118f33e533204ef76b22233e4f2fdeb1994835
parentdev-python/flask-babel: Bump to 1.0.0 (diff)
downloadgentoo-531b96fb745d5474c3f0b87668f5c8526baf6922.tar.gz
gentoo-531b96fb745d5474c3f0b87668f5c8526baf6922.tar.bz2
gentoo-531b96fb745d5474c3f0b87668f5c8526baf6922.zip
dev-python/httpretty: Add missing test deps
Closes: https://bugs.gentoo.org/719766 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httpretty/httpretty-1.0.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..eb33b6f3b1d3
--- /dev/null
+++ b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+# redis skipped as it requires a redis server running
+DEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+ # tests requiring network access
+ rm tests/functional/test_passthrough.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}