summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 01:04:07 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 01:08:54 +0300
commit531e80bd475132687f17641d2d6f2fc781416ffe (patch)
tree9d9213d137a627f84c2786ee4b7beb5afb96418d
parentgnome-extra/gnome-contacts: bump to 3.32.1 (diff)
downloadgentoo-531e80bd475132687f17641d2d6f2fc781416ffe.tar.gz
gentoo-531e80bd475132687f17641d2d6f2fc781416ffe.tar.bz2
gentoo-531e80bd475132687f17641d2d6f2fc781416ffe.zip
mail-client/evolution: bump to 3.32.4
Closes: https://bugs.gentoo.org/689582 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.32.4.ebuild154
-rw-r--r--mail-client/evolution/files/3.32.4-gtk-doc-fix1.patch88
-rw-r--r--mail-client/evolution/files/3.32.4-gtk-doc-fix2.patch29
4 files changed, 272 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index 5301d9a2432f..c2e8d4461e29 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1 +1,2 @@
DIST evolution-3.30.5.tar.xz 11995960 BLAKE2B 4a2ac539e88467148dd3be2bf2607be55ea39dfb0ceb89183a6f4fa3ee66c1973690c4e540a7405743c202aa777ad9aa147600390e909ffc93cb2dae1ebb62d9 SHA512 1d776fdb0da4166d9346ad4cd05d7ee050e0bf3ac1edc1f7d3fb4ba8909e35429e8d076a5b6e223f3fc94e2a8ad6337205c1d648220a3fdf593bae64d9c975d1
+DIST evolution-3.32.4.tar.xz 11793452 BLAKE2B bb009a5881cca6724b804a1203d393003f92ef9f6a8fa9692fc42344224b0b2f5def5c05160d46bbf7f76b9ae9bfa1737f78207aee7038540f410df57f7a76cd SHA512 a09ef7e39a73449a8a897c430fb97aadac01790d350b21e456d86cc785b67bdc2b542771ef9c6daa160fc0c1946b4a4e3eb9429a8ad1d69284698cbdb0ac4931
diff --git a/mail-client/evolution/evolution-3.32.4.ebuild b/mail-client/evolution/evolution-3.32.4.ebuild
new file mode 100644
index 000000000000..d83be2ff5b83
--- /dev/null
+++ b/mail-client/evolution/evolution-3.32.4.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2 flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="archive +bogofilter geolocation gtk-doc highlight ldap spamassassin spell ssl +weather ytnef"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitely needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+# automagic libunity dep
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.4:=[gtk]
+ >=app-text/enchant-1.6.0:0
+ >=dev-libs/glib-2.46:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-2.42:2.4
+ >=net-libs/webkit-gtk-2.16.0:4
+ >=x11-libs/cairo-1.9.15:=[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libnotify-0.7:=
+ >=x11-misc/shared-mime-info-0.22
+
+ >=app-text/iso-codes-0.49
+ dev-libs/atk
+ gnome-base/dconf
+ >=dev-libs/libical-3.0.2:=
+ x11-libs/libSM
+ x11-libs/libICE
+
+ archive? ( >=app-arch/gnome-autoar-0.1.1[gtk] )
+ geolocation? (
+ >=media-libs/libchamplain-0.12:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.10.0
+ x11-libs/mx:1.0 )
+ ldap? ( >=net-nds/openldap-2:= )
+ spell? ( app-text/gtkspell:3 )
+ ssl? (
+ >=dev-libs/nspr-4.6.1:=
+ >=dev-libs/nss-3.11:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+ ytnef? ( net-mail/ytnef )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ bogofilter? ( mail-filter/bogofilter )
+ highlight? ( app-text/highlight )
+ spamassassin? ( mail-filter/spamassassin )
+ !gnome-extra/evolution-exchange
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake-utils_src_prepare call, if that works
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PV}-gtk-doc-fix{1,2}.patch
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DENABLE_SMIME=$(usex ssl)
+ -DENABLE_GNOME_DESKTOP=ON
+ -DWITH_ENCHANT_VERSION=1
+ -DENABLE_CANBERRA=ON
+ -DENABLE_AUTOAR=$(usex archive)
+ -DWITH_HELP=ON
+ -DENABLE_YTNEF=OFF
+ -DWITH_BOGOFILTER=$(usex bogofilter)
+ -DWITH_SPAMASSASSIN=$(usex spamassassin)
+ -DENABLE_GTKSPELL=$(usex spell)
+ -DENABLE_TEXT_HIGHLIGHT=$(usex highlight)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_CONTACT_MAPS=$(usex geolocation)
+ -DENABLE_YTNEF=$(usex ytnef)
+ -DENABLE_PST_IMPORT=OFF
+ -DWITH_GLADE_CATALOG=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Problems with prelink:
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731680
+ # https://bugzilla.gnome.org/show_bug.cgi?id=732148
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
+ echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
+ doenvd "${T}"/99${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/mail-client/evolution/files/3.32.4-gtk-doc-fix1.patch b/mail-client/evolution/files/3.32.4-gtk-doc-fix1.patch
new file mode 100644
index 000000000000..54a5fc714def
--- /dev/null
+++ b/mail-client/evolution/files/3.32.4-gtk-doc-fix1.patch
@@ -0,0 +1,88 @@
+From 925070132ca90787ccfe9a993c3eb7e0feb74fa7 Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Mon, 22 Jul 2019 16:06:21 +0800
+Subject: [PATCH] M!28 - Include LDFLAGS in gtkdoc-scangobj command line
+
+When a library provides no way to find linker flags for linking with it,
+the build system usually depends on the user to necessary put -L flags
+in LDFLAGS environment variable in order to find it. However, GtkDoc
+module constructs the command line by itself, and it forgets to add
+LDFLAGS to the command line of gtkdoc-scangobj.
+
+It is especially important to include LDFLAGS on non-GNU systems. For
+example, FreeBSD libc doesn't include a gettext implementation. GLib
+requires gettext, and it pulls in an external gettext runtime for it.
+However, gettext-runtime doesn't include a .pc file, so LDFLAGS is
+required if gettext-runtime isn't installed in the same prefix as GLib.
+Failing to include LDFLAGS in --ldflags passed to gtkdoc-scangobj can
+result in a linking error because -lintl cannot be found.
+
+In evolution-data-server we are lucky most of the time because it
+depends on a lot of external libraries. These external libraries are
+likely to be installed in the same prefix as gettext-runtime, so not
+using LDFLAGS doesn't cause linking failure because required flags are
+already pulled in by other libraries. In fact, this problem was found
+when building libical, which uses a similar GtkDoc.cmake file.
+
+In addition to the change to include LDFLAGS, this commit also changes
+the following things:
+
+ - Instead of constructing _scangobj_ldflags in reverse order, do it in
+ normal order. Appending is easier to understand than prepending, and
+ the linker also interprets -L and -l flags in normal order.
+
+ - Move -L${LIB_INSTALL_DIR} to the bottom. This is what the comment
+ says, and it is expected to work because we no longer constructs
+ _scangobj_ldflags in reverse order.
+
+Closes https://gitlab.gnome.org/GNOME/evolution-data-server/merge_requests/28
+---
+ cmake/modules/GtkDoc.cmake | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/modules/GtkDoc.cmake b/cmake/modules/GtkDoc.cmake
+index cc6cc007a..0ba1a7a78 100644
+--- a/cmake/modules/GtkDoc.cmake
++++ b/cmake/modules/GtkDoc.cmake
+@@ -96,9 +96,8 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ list(APPEND _scangobj_deps ${opt})
+ endforeach(opt)
+
+- # Add them as the last, thus in-tree headers/libs have precedence
++ # Add it as the last, thus in-tree headers have precedence
+ list(APPEND _scangobj_cflags_list -I${INCLUDE_INSTALL_DIR})
+- list(APPEND _scangobj_ldflags -L${LIB_INSTALL_DIR})
+
+ if(_scangobj_deps)
+ list(REMOVE_DUPLICATES _scangobj_deps)
+@@ -122,7 +121,7 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ if(NOT _output_name)
+ set(_output_name ${opt})
+ endif(NOT _output_name)
+- set(_scangobj_ldflags "-L$<TARGET_FILE_DIR:${opt}> -l${_output_name} ${_scangobj_ldflags}")
++ set(_scangobj_ldflags "${_scangobj_ldflags} -L$<TARGET_FILE_DIR:${opt}> -l${_output_name}")
+
+ if(_target_type STREQUAL "SHARED_LIBRARY" OR (_target_type STREQUAL "MODULE_LIBRARY"))
+ set(_scangobj_ld_lib_dirs "${_scangobj_ld_lib_dirs}:$<TARGET_FILE_DIR:${opt}>")
+@@ -133,12 +132,18 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ endif(TARGET ${opt})
+ endforeach(opt)
+
++ # Add extra flags from LDFLAGS environment variable
++ set(_scangobj_ldflags "${_scangobj_ldflags} ${CMAKE_SHARED_LINKER_FLAGS}")
++
+ foreach(opt IN LISTS _scangobj_deps)
+ if(NOT TARGET ${opt})
+ set(_scangobj_ldflags "${_scangobj_ldflags} ${opt}")
+ endif(NOT TARGET ${opt})
+ endforeach(opt)
+
++ # Add it as the last, thus in-tree libs have precedence
++ set(_scangobj_ldflags "${_scangobj_ldflags} -L${LIB_INSTALL_DIR}")
++
+ set(_scangobj_prefix ${CMAKE_COMMAND} -E env LD_LIBRARY_PATH="${_scangobj_ld_lib_dirs}:${LIB_INSTALL_DIR}:$ENV{LD_LIBRARY_PATH}")
+
+ if(NOT (_scangobj_cflags STREQUAL ""))
+--
+2.20.1
+
diff --git a/mail-client/evolution/files/3.32.4-gtk-doc-fix2.patch b/mail-client/evolution/files/3.32.4-gtk-doc-fix2.patch
new file mode 100644
index 000000000000..56e66eae8938
--- /dev/null
+++ b/mail-client/evolution/files/3.32.4-gtk-doc-fix2.patch
@@ -0,0 +1,29 @@
+From 78dc64008f1312a97eaa56b5c12f93a2bfa3b096 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 5 Aug 2019 12:55:23 +0200
+Subject: [PATCH] Include also CFLAGS in gtkdoc-scangobj command line
+
+The LDFLAGS could imply certain compile options being used (like -fPIC),
+but these CFLAGS were not passed to gtkdoc-scangobj, thus the compilation
+could fail.
+
+Related to https://gitlab.gnome.org/GNOME/evolution-data-server/merge_requests/28
+---
+ cmake/modules/GtkDoc.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/modules/GtkDoc.cmake b/cmake/modules/GtkDoc.cmake
+index 0ba1a7a78..2dfc4d691 100644
+--- a/cmake/modules/GtkDoc.cmake
++++ b/cmake/modules/GtkDoc.cmake
+@@ -98,6 +98,7 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+
+ # Add it as the last, thus in-tree headers have precedence
+ list(APPEND _scangobj_cflags_list -I${INCLUDE_INSTALL_DIR})
++ list(APPEND _scangobj_cflags_list ${CMAKE_C_FLAGS})
+
+ if(_scangobj_deps)
+ list(REMOVE_DUPLICATES _scangobj_deps)
+--
+2.20.1
+