summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-10 20:41:52 +0100
committerDavid Seifert <soap@gentoo.org>2018-03-10 20:43:34 +0100
commit532f0fbbe961ef70adc990697c8a92d5b027094e (patch)
treee647cdce3d25f8ec447a6f80950d156cad3ffb12
parentdev-libs/beecrypt: Build in C++14 mode (diff)
downloadgentoo-532f0fbbe961ef70adc990697c8a92d5b027094e.tar.gz
gentoo-532f0fbbe961ef70adc990697c8a92d5b027094e.tar.bz2
gentoo-532f0fbbe961ef70adc990697c8a92d5b027094e.zip
media-libs/libsidplayfp: Build in C++14 mode
Closes: https://bugs.gentoo.org/649832 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild b/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
index 8d0ef050961a..93296cb979e6 100644
--- a/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
+++ b/media-libs/libsidplayfp/libsidplayfp-1.8.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils versionator
+
+inherit eutils flag-o-matic versionator
DESCRIPTION="A library for the sidplay2 fork with resid-fp"
HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
@@ -13,14 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="cpu_flags_x86_mmx static-libs"
-DOCS=( AUTHORS NEWS README TODO )
-
src_prepare() {
# fix automagic. warning: modifying .ac triggers maintainer mode.
sed -i -e 's:doxygen:dIsAbLe&:' configure || die
}
src_configure() {
+ # relies on undocumented "uint" type in libstdc++
+ # bug 649832
+ append-cxxflags -std=c++14
+
econf \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_mmx mmx)