summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-26 17:15:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-26 19:07:49 +0100
commit5337f0da7362132e4a7a59ce0d33755e771c2fac (patch)
tree3020bd4e3c07560d16a4936a50f2f5150aef74c8
parentvirtual/perl-Module-CoreList: add 5.202.311.250 (diff)
downloadgentoo-5337f0da7362132e4a7a59ce0d33755e771c2fac.tar.gz
gentoo-5337f0da7362132e4a7a59ce0d33755e771c2fac.tar.bz2
gentoo-5337f0da7362132e4a7a59ce0d33755e771c2fac.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.8.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/Manifest b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
index 22d71a22bbca..8d55035fa8dd 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/Manifest
+++ b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-whiskermenu-plugin-2.8.0.tar.bz2 187093 BLAKE2B 8836dbb7691dff9c2abe03e996514b07e73532140f685dd42c7453638a0f7fba2c149553c098e9dfb713e111f14ce21f5738dd338f333fe5a980c0fc2c06ce68 SHA512 844c34ea85e2574dc39e90bb08774c3e7e9e3e13a0a35b1da916d3b3187f158d9f6e130312f2545e26cd214f98cc03461a857ad4c91893febe9942ad08c58a70
DIST xfce4-whiskermenu-plugin-2.8.1.tar.bz2 187656 BLAKE2B 32dd2a97cdf2d2194d0246898a7427045c0c045dd96f093f469db3fc02e1948699b6bc899db68eb374784ede8ac350aafdd597342b5b266d240bc533dd0eac32 SHA512 e6ff671f8b7eca6530d807497378a55ed89ee6ab242a3d72a9321692595e242a42324e13eac37a82c292b866d1107e1fdd21be95ed0ffc97b4b26424be88972d
+DIST xfce4-whiskermenu-plugin-2.8.2.tar.bz2 188096 BLAKE2B 64326da26c41041625be58fddf1f8e6138045059a8f77a0a892382f6d09c5895535ea8bfbb2c8a6d6f47fa83bd6f330231d3ed8f1e646dc4ab7917bbe476de6c SHA512 c3cfd1032ce313976ecc42c33b5a4a2727c89a7cb7c053227cfa8ee3c2cf722ba6a360c7ac819456c1bf89dd5c3c768276220da13fe3e5cb955d8c9ad4852824
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.8.2.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.8.2.ebuild
new file mode 100644
index 000000000000..8594e3c7a453
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.8.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake xdg-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="accountsservice wayland"
+
+DEPEND="
+ virtual/libintl
+ x11-libs/gtk+:3
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/garcon-0.6.4:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+ accountsservice? (
+ >=sys-apps/accountsservice-0.6.45
+ )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.7
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# upstream does fancy stuff in other build types
+CMAKE_BUILD_TYPE=Debug
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ -DENABLE_LINK_TIME_OPTIMIZATION=OFF
+ -DENABLE_ACCOUNTS_SERVICE=$(usex accountsservice)
+ -DENABLE_GTK_LAYER_SHELL=$(usex wayland)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}