summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-24 14:10:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-24 14:42:21 +0100
commit533b02cd41431c85987a01fcc4ff4fabb9523909 (patch)
treedaacfe9f93eebe3793ea0622c0d62604e206147b
parentdev-python/Nuitka: Bump to 1.9.1 (diff)
downloadgentoo-533b02cd41431c85987a01fcc4ff4fabb9523909.tar.gz
gentoo-533b02cd41431c85987a01fcc4ff4fabb9523909.tar.bz2
gentoo-533b02cd41431c85987a01fcc4ff4fabb9523909.zip
dev-python/sentry-sdk: Bump to 1.37.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.37.0.ebuild131
2 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index cf4d81df2e51..fa962c62ce15 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -4,3 +4,4 @@ DIST sentry-python-1.33.1.gh.tar.gz 431232 BLAKE2B 8f08e2ae58fa7d55384be9102a6f2
DIST sentry-python-1.34.0.gh.tar.gz 432143 BLAKE2B d5a1376e88b4377ee0f416229364586cd69d76a72a31f1d7a5128c5aba6988d5cbfaf405afa39d52926ba64c0b29b48577d8e102427aec08dead41356a3dbbf5 SHA512 b4d6d4751bde829aca7cec418d46fb5ac44d59bcfd71e4b6e3057b70ea38e96dc3eeaa3b8ce61f9d7d0ccc9845ba741c9aacdc58e6fea56c1f33b5c39118c35f
DIST sentry-python-1.35.0.gh.tar.gz 438978 BLAKE2B 84d016fd24895eab240d97d99c5ac11f332f72c487b82205680513103d5a684ad25b4dbb6fe7863d681c965239079f1208b660a48bc21e508b57db04466e91b7 SHA512 fb136cb0542a9ca7db7e5bbcfe6178cdee90b80c634c9f1f54ad769b403fbe48ab9f23f66e33c1b7cc0f22d53811c0b1ae767604df5f2209c3568eebdc643b6a
DIST sentry-python-1.36.0.gh.tar.gz 441169 BLAKE2B c338de881abf5bce90ec72e48c5378d269a258a07ca6dc30327590c98fb15a6a8b7cb57db055ef73df7b2cb35bc429f5dbb43fe42fb91f0c1c9b720f4d456cb7 SHA512 4ec1886875156877fed18618d6997e46850e9548f82706dbcc76989779b5d94054e588032b0f2b1a7fbc6370dd1c93169b77d8ed05a875854a858f7e63d8514c
+DIST sentry-python-1.37.0.gh.tar.gz 447094 BLAKE2B 74299d4efb1842965facbb9d6a957f21c42909eac26545d2b4838be83641049cb277d6525052209e9c7d4d3801b99f75d7350c29b18c2e3909e16e7246056967 SHA512 6dd5be6561075646967c1b7b1fd9eeaf07fe45cd71a64898265d49b3a89a5ffcc3a0ceea8698e389b9e57f0dbe42073c6d3df947dc8bfd46cc3e269330dbe3a4
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.37.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.37.0.ebuild
new file mode 100644
index 000000000000..ddb8aa60a9e3
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.37.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+ # requires AWS access
+ tests/integrations/aws_lambda
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+ # this is not even funny
+ tests/test_utils.py::test_installed_modules
+ # flaky hypothesis stuff
+ tests/test_serializer.py::test_bytes_serialization_repr_many
+ # TODO
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p aiohttp -p pytest_forked
+}