summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2022-08-20 20:39:09 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-31 11:26:03 +0300
commit535674e596852ccd6a963692e253c2a93c3c5b1e (patch)
tree2261dc56ee829b98f6c6215a3993b057885bff69
parentapp-admin/doctl: drop old ebuilds (diff)
downloadgentoo-535674e5.tar.gz
gentoo-535674e5.tar.bz2
gentoo-535674e5.zip
app-admin/doctl: version bump to 1.79
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/26933 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-admin/doctl/Manifest1
-rw-r--r--app-admin/doctl/doctl-1.79.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/doctl/Manifest b/app-admin/doctl/Manifest
index f1379313e549..f2e3e2f3aa87 100644
--- a/app-admin/doctl/Manifest
+++ b/app-admin/doctl/Manifest
@@ -1 +1,2 @@
DIST doctl-1.78.0.tar.gz 5658172 BLAKE2B 3213219b1cfbc395c742a59a6bee1c6232f222455ac126de9ce51470a56ebaa9680de4d332cd31580a7ddb9f748b19a8abadef17ff6ea4265dffc2c42b1bb16d SHA512 193fe775885c78312eb6ba14bd34d109ee31acf41cfe68dbacbf6ab19864509b774c658aecf7a61d470598ca89829a6737ea6796eb970b3075d8f37aef747dbe
+DIST doctl-1.79.0.tar.gz 5661873 BLAKE2B 276cf8355f982070e2a44306f0d2bca5c269eccab3d67fe8b1b68171d393bacfb857e78fc66e036b0c039fa4bcf26505c029a1ba5ccebfeebf81d4dc3f51d82f SHA512 8257fc8d32ee097f78420138bd12572235dd7a6cead65fe1a666a9686d2f31add50a85a99fed45aae641b583b47b079a0ea3ce6e9e017c6ecfc7dfc14f7b5abd
diff --git a/app-admin/doctl/doctl-1.79.0.ebuild b/app-admin/doctl/doctl-1.79.0.ebuild
new file mode 100644
index 000000000000..3f5680240a83
--- /dev/null
+++ b/app-admin/doctl/doctl-1.79.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 edo go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
+ -X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
+ -X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
+ -X github.com/digitalocean/doctl.Label=release"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
+
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}