summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 03:55:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 04:01:25 +0200
commit535f487e27671426f73bf583bf4e859261938d41 (patch)
treed103b3bf50693e2c32a8694af98bbb8b89c73fa7
parentdev-python/urwid: Bump to 2.6.12 (diff)
downloadgentoo-535f487e27671426f73bf583bf4e859261938d41.tar.gz
gentoo-535f487e27671426f73bf583bf4e859261938d41.tar.bz2
gentoo-535f487e27671426f73bf583bf4e859261938d41.zip
dev-python/mcbootflash: Bump to 9.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mcbootflash/Manifest1
-rw-r--r--dev-python/mcbootflash/mcbootflash-9.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mcbootflash/Manifest b/dev-python/mcbootflash/Manifest
index 9fd6f2c44a00..ac5f53e1e9a2 100644
--- a/dev-python/mcbootflash/Manifest
+++ b/dev-python/mcbootflash/Manifest
@@ -1,3 +1,4 @@
DIST mcbootflash-8.0.1.tar.gz 24906 BLAKE2B 2af5c73de29aa089d33047179ce196507ab1ed1ae224b6f680341a818d8056915271b121cf1ac32f31dd5e33e095f2b82fcddf5907bdb5513a17e009ac242f7f SHA512 fc4093873bbfc0a29d2c09b2f62247dd659b4c9d531613a2a18d6b452f7a0e573b5fa087d82686045af1ba6f7811ca3ccba0f109ada71c42925e8c01faa0fe1d
DIST mcbootflash-8.0.2.tar.gz 27121 BLAKE2B caded3a13266db46ac1b9f35c0a027e9dbfa2c430da96992bf689d4b32574406a7d0c736da82dbe7c473189a8941db8548f59828010e755f33c0342c8c593be2 SHA512 542dcf9af6c22f2deae786fa547e99e4df07b8e3eda7b007a9ead96386c2bf880d8485985b3de399ecd496bf982b6a0308c3f82b49c5914bca09c961822566c6
DIST mcbootflash-9.0.0.tar.gz 26736 BLAKE2B d813e06f88192d44139fe1dc127df6cb26d21f5716288e3bb59989ac362664b1c3a66e857fe702e8691d945ecaf5dace56b43ab967f029bc51583b0a1603fcbd SHA512 92854a1f7c4ecebff5bce12e10131154fa23ae078618fb7a7757f325b49cae7c1a0d3505e25a2c2faa5101adfb2786be90f703a074304a61c55590267d2cdf38
+DIST mcbootflash-9.0.1.tar.gz 26858 BLAKE2B d8d8486a8713d46f7b93443dcfd9cbd9a93452fa7c8e76aeba1f4bfbf52765fbe3807fe8206b994015c094f9fba1626d5a3bb2fa93bd6b6400a9cbaaee7c19a9 SHA512 0c001a0a2c10e9d4bf111136d08ec89c4bc62568934ef9d8b75d7c58d59f451f5459ccc387c72424e8d16c5e49e7bba903efce403f41923ca33d87c2290a84e9
diff --git a/dev-python/mcbootflash/mcbootflash-9.0.1.ebuild b/dev-python/mcbootflash/mcbootflash-9.0.1.ebuild
new file mode 100644
index 000000000000..2821aae561f3
--- /dev/null
+++ b/dev-python/mcbootflash/mcbootflash-9.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flash firmware to devices running Microchip's 16-bit bootloader"
+HOMEPAGE="
+ https://pypi.org/project/mcbootflash/
+ https://github.com/bessman/mcbootflash/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/bincopy-20.0.0[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-reserial[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --replay
+}