summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-25 09:45:31 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-25 09:49:18 +0100
commit5367726551b5e242fd2e11cd878630e2671d9e9e (patch)
tree479145a938c2c66621159c6365c119b82a13e6b8
parentsys-apps/portage: Stabilize 3.0.61-r1 ppc, #921933 (diff)
downloadgentoo-53677265.tar.gz
gentoo-53677265.tar.bz2
gentoo-53677265.zip
dev-ruby/activesupport: add 7.1.3.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.1.3.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index dc1ce713110a..5a38fea999e2 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -2,4 +2,5 @@ DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f
DIST rails-6.1.7.7.tgz 11041447 BLAKE2B 3f59325aa86d3b7d6e0773b9eb2b895a26b644109be8df0b0d9abbab8e6c77f76d316c717ecce4e2d79d3247559504a7452a8037d2d52a6cf95fbacd7f8b8612 SHA512 f9af4eebb3bffec78832f92be6158c71c147e265b54e8e368a06c762bfd1a7992256b3e9286aeb59eee69ba56be28d381a715eb13f99b9babfd9b7ce8051e210
DIST rails-7.0.8.1.tgz 11089378 BLAKE2B 5d92087402d8aa2b86759ec92c44091a7a0f8a22959e0510f10417f88e54f9e1e6a14c4e9519033cd63bdd1f54f72b91bff8a3318a3264c39311317fb67e8b63 SHA512 74f467f7d3e5ec88560448e206a8f0cdf55bad60dd9eac019224fce86a766ee9d0c4afbd4eaae30dacfe34beebcff6aa9d3c5c99be9c8ad5c385817fe409afc8
DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
+DIST rails-7.1.3.2.tgz 10914950 BLAKE2B 419e6817958efcc5dbbb47d24498decff48fca9748c9f4069bcd353a4644fa623caf79c4072db0944139ac991d14623013683f69cef3126fa63348cc0612655b SHA512 0a58e7b125eb97f94a8a75bacd421d7197e6ad78d24651aecfe82e41c024ccfa42a9de0664099f55cd6ac6a41fd7f09cdc3177ed2b809b0be7d7df1639424f9d
DIST rails-7.1.3.tgz 10900323 BLAKE2B a83ca4ee656e93241fa0460d8df197904a4eef310cf25bce6db6167bad87c8d0644533fa6e224ec959a4e10005164e0f981e14e8b23cee14e2747117be9da712 SHA512 df1128d1403ab82d218d2057c7c86e646594f97a8c6fcf5648a66440d52e5c20a4ceb0c13e70b6153152b44f62d8a1e20f3776acff5c55bc54d006cb7da32d12
diff --git a/dev-ruby/activesupport/activesupport-7.1.3.2.ebuild b/dev-ruby/activesupport/activesupport-7.1.3.2.ebuild
new file mode 100644
index 000000000000..e265e8725432
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.1.3.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+msgpack test"
+REQUIRED_USE="test? ( msgpack )"
+
+PATCHES=( "${FILESDIR}/${PN}-7.1.1-backport-pr50097.patch" )
+
+RUBY_S="rails-${PV}/${PN}"
+
+# bigdecimal and mutex_m are bundled with ruby as default gems
+ruby_add_rdepend "
+ dev-ruby/base64
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/connection_pool-2.2.5
+ dev-ruby/drb
+ >=dev-ruby/i18n-1.6:1
+ >=dev-ruby/minitest-5.1
+ dev-ruby/tzinfo:2
+ msgpack? ( >=dev-ruby/msgpack-1.7.0 )
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack:3.0
+ dev-ruby/rexml
+ dev-ruby/mocha
+ >dev-ruby/minitest-5.15.0:*
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|execjs\|jquery-rails\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\|rack-test\|terser\|cgi\|net-smtp\|net-imap\|net-pop\|digest\|matrix\|web-console\|error_highlight\|jbuilder\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/^group :test/,/^end/ s:^:#:' \
+ -e '/^\s*group :\(db\|doc\|rubocop\|job\|cable\|lint\|mdl\|storage\|ujs\|test\|view\) do/,/^\s*end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}