summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-08 19:32:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-08 19:32:18 +0100
commit53693069697c0518a7d46180f69cacc1e2b9b946 (patch)
tree97f01df2e44b8f350cb07efbd5dc46a26a7b031a
parentdev-python/iminuit: Bump to 2.25.1 (diff)
downloadgentoo-53693069.tar.gz
gentoo-53693069.tar.bz2
gentoo-53693069.zip
dev-python/reportlab: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-4.1.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 40e9c788b581..cc3eb0e5e8d5 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-4.0.9.tar.gz 3684146 BLAKE2B 1db674238d481f77c8847c56527d73ea209a66df9d520c590460b91fa118bbdeb103fa37fc6fbc23f5cb28206c9bcf1e663ad0ab3b52f003e9d72b26b630e8fd SHA512 5ae2ce70e108b84e84d88c6ba54015d390f79552bdcf40564fa803d33428ea67e7a08824a68c836475e6dfeaf75b00b56c30b81e4ec82011fdbc8978a1cfb80c
+DIST reportlab-4.1.0.tar.gz 3146958 BLAKE2B fef5ed94514685e352d3aa2a76dac7d7f20699999f073e03839d18bce5f884c3d44c6ef635e7d77b2d32707c200f3f067ebea90312642db22488597c434e2eec SHA512 998f49cdbbea0e91bc0c61f877936b0eb62130723f565548aa5ab7a01adc59d688fcf7ce69783142fb4bbec4a97d91b8b1b2495701c6eba25b1e9878d15f6625
diff --git a/dev-python/reportlab/reportlab-4.1.0.ebuild b/dev-python/reportlab/reportlab-4.1.0.ebuild
new file mode 100644
index 000000000000..886e9d4f2537
--- /dev/null
+++ b/dev-python/reportlab/reportlab-4.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+"
+SRC_URI+="
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_sphinx docs/source
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ cat > local-setup.cfg <<-EOF || die
+ [OPTIONS]
+ no-download-t1-files = 1
+ EOF
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py --post-install --verbosity=2 ||
+ die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}