summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-24 18:13:54 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-24 18:29:31 +0200
commit536fdb1fe36f6cc679587ee72e30219316683f46 (patch)
treeef7441a14777cfe55a848a4f102bbd5c1f581dc9
parentsys-apps/ipmiutil: Removed old. (diff)
downloadgentoo-536fdb1fe36f6cc679587ee72e30219316683f46.tar.gz
gentoo-536fdb1fe36f6cc679587ee72e30219316683f46.tar.bz2
gentoo-536fdb1fe36f6cc679587ee72e30219316683f46.zip
dev-util/squashdelta: Bump to 0.1.1 (bugfix/refactor)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/squashdelta/Manifest1
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/squashdelta/Manifest b/dev-util/squashdelta/Manifest
index 0516c3d4907a..82dff9aaff5c 100644
--- a/dev-util/squashdelta/Manifest
+++ b/dev-util/squashdelta/Manifest
@@ -1 +1,2 @@
+DIST squashdelta-0.1.1.tar.bz2 78504 BLAKE2B f9aa13b3af35bd97650b31fac718837763b73c2817548a3fde75841993092d717ea78826a3e29d472290d4f9164f8cfcc9f9999613f199c21251080584dbd9f7 SHA512 efe90831e412ed6627d44390054dc89339e85bcd3be452f16fb32d00989bbdc9480dbefcea624941b4866a686a356b0371c33de31903afa70af26eecbe902844
DIST squashdelta-0.1.tar.bz2 77702 BLAKE2B c36a90e5bb0c22519fdd6229131039b881ccda82117a8180959e463debf767bc2382cc7e38645003cb23ae8e58492aaed849d1951adaedea56837900fda0025f SHA512 1ce93b59b6c51be49aaaee9576049677c8ba146fa3a17c7d3552440a1c0ebe93fb4d8cbe1182db691e2c9552713ecfeef0e50d95f7e94218c341c51364bf724f
diff --git a/dev-util/squashdelta/squashdelta-0.1.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
new file mode 100644
index 000000000000..9883a7ef38f0
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI="https://www.github.com/mgorny/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}