summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 00:41:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 00:43:18 +0100
commit5373d3f7ca609d8eb2e46745ad4ae47163c65887 (patch)
tree9df48a1b4c166cced5eac583f604b6a6ff199ef8
parentmedia-libs/libbdplus: EAPI-7 bump (diff)
downloadgentoo-5373d3f7ca609d8eb2e46745ad4ae47163c65887.tar.gz
gentoo-5373d3f7ca609d8eb2e46745ad4ae47163c65887.tar.bz2
gentoo-5373d3f7ca609d8eb2e46745ad4ae47163c65887.zip
media-libs/libbdplus: Minor style fixes, drop superfluous DOCS
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild11
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild11
2 files changed, 12 insertions, 10 deletions
diff --git a/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild b/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild
index 6b225c0947f2..8bffc8107314 100644
--- a/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild
+++ b/media-libs/libbdplus/libbdplus-0.1.2-r1.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit multilib-minimal
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
else
@@ -19,13 +20,13 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="aacs"
-RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+RDEPEND="
+ dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
dev-libs/libgpg-error[${MULTILIB_USEDEP}]
- aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
DEPEND="${RDEPEND}"
-DOCS=( ChangeLog README.txt )
-
src_prepare() {
default
[[ ${PV} == 9999 ]] && eautoreconf
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
index fc1840912257..8bffc8107314 100644
--- a/media-libs/libbdplus/libbdplus-9999.ebuild
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit multilib-minimal
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
else
@@ -19,13 +20,13 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="aacs"
-RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+RDEPEND="
+ dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
dev-libs/libgpg-error[${MULTILIB_USEDEP}]
- aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
DEPEND="${RDEPEND}"
-DOCS=( ChangeLog README.md )
-
src_prepare() {
default
[[ ${PV} == 9999 ]] && eautoreconf