summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-01-20 18:30:03 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-01-20 18:32:48 +0300
commit5379876c26cdc58bcff73df57e288f07c2532565 (patch)
treefa9af60339cd497812fc9cc6209e8669642a0411
parentnet-dns/bind: Version bump (v9.16.10) (diff)
downloadgentoo-5379876c26cdc58bcff73df57e288f07c2532565.tar.gz
gentoo-5379876c26cdc58bcff73df57e288f07c2532565.tar.bz2
gentoo-5379876c26cdc58bcff73df57e288f07c2532565.zip
net-dns/bind-tools: Version bump (v9.16.10)
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--net-dns/bind-tools/Manifest1
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.10.ebuild149
2 files changed, 150 insertions, 0 deletions
diff --git a/net-dns/bind-tools/Manifest b/net-dns/bind-tools/Manifest
index 6039aada0eac..d8e9b8f5d233 100644
--- a/net-dns/bind-tools/Manifest
+++ b/net-dns/bind-tools/Manifest
@@ -1,3 +1,4 @@
+DIST bind-9.16.10.tar.xz 3269696 BLAKE2B f262235164584173ac757bff6a177751e4cc19a9b68fe240f06c5bc3e0a51b9a05edc18a00342016b5546c531678894bccb7d7a353c5a0cb8b4f1cd89b50e504 SHA512 cb140fd577042ddeb7a47bc5e132d405d885bed22c9aeecb3d91a9115481ce4380ef191f78ba7acc9580ad0d4c8ed2658643007adf5b5527060879f34efdf8f7
DIST bind-9.16.6.tar.xz 3228368 BLAKE2B 0c2265fe0e006679733a4f7610b0c33bb8e2bd32caf26dca8cfedbea0e08df9e7665cbbbf5321199bd2e30b97ad5b0146ae4e8a9a78abadbe6d067bbd1ad8a3a SHA512 37f57db6d1633cc85a4d954a69bbb3372c65ac43fef965df5aee8dcdd32153bb5b0c6d0d5f00f353dd4464c71d74dc8e801937b930e2b8f6799fa77af5f243e0
DIST bind-9.16.7.tar.xz 3241476 BLAKE2B ed11be4cb11cf0b77dfefd4284bdbe2d0e8dfd4c8b46e2966f3f0afc60a5df2ff3545a10209ede65f55f7d5dab3ed10945b98908c1b6bf35723c89c6d940a001 SHA512 176c84657e8a7b10a7ca93c939ca6a7fcdefb22f9200c3f01be59bcd8990dee27b8dc0970299225bcbe0f1aa8f49a67c80c4a9853895ffbcd685adb9674e7768
DIST bind-9.16.8.tar.xz 3253744 BLAKE2B 013c61d7298f334aae0165fa0ddaf4eb8fc22021b161f3a53843b4860456c133f1f33316387fcf2d7267a992844de44467eaec70c8064c77f9baef00f37fb98f SHA512 803af842b4f83c16556036f3a2a52b4aeab4781bafb35385b786a3331cf17ef6148c23928f6903fd371337ba92870d7a8548f5d178b805d160d0af34af45fee7
diff --git a/net-dns/bind-tools/bind-tools-9.16.10.ebuild b/net-dns/bind-tools/bind-tools-9.16.10.ebuild
new file mode 100644
index 000000000000..f983773f1fac
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.16.10.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="https://www.isc.org/software/bind"
+SRC_URI="https://downloads.isc.org/isc/bind9/${PV}/${MY_P}.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps doc gssapi idn ipv6 libedit libressl readline xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+COMMON_DEPEND="
+ dev-libs/libuv:=
+ caps? ( sys-libs/libcap )
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ xml? ( dev-libs/libxml2 )
+ idn? ( net-dns/libidn2:= )
+ gssapi? ( virtual/krb5 )
+ libedit? ( dev-libs/libedit )
+ !libedit? (
+ readline? ( sys-libs/readline:= )
+ )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# sphinx required for man-page and html creation
+BDEPEND="
+ doc? ( dev-python/sphinx )
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# bug 479092, requires networking
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ export LDFLAGS="${LDFLAGS} -L${EPREFIX}/usr/$(get_libdir)"
+
+ # Disable tests for now, bug 406399
+ sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+ # bug #220361
+ rm aclocal.m4 || die
+ rm -rf libtool.m4/ || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --without-python
+ --without-libjson
+ --without-zlib
+ --without-lmdb
+ --without-maxminddb
+ --disable-geoip
+ --with-openssl="${EPREFIX}"/usr
+ $(use_with idn libidn2)
+ $(use_with xml libxml2)
+ $(use_with gssapi)
+ $(use_with readline)
+ $(use_enable caps linux-caps)
+ AR="$(type -P $(tc-getAR))"
+ )
+
+ # bug 607400
+ if use libedit ; then
+ myeconfargs+=( --with-readline=-ledit )
+ elif use readline ; then
+ myeconfargs+=( --with-readline=-lreadline )
+ else
+ myeconfargs+=( --without-readline )
+ fi
+
+ # bug 344029
+ append-cflags "-DDIG_SIGCHASE"
+
+ # to expose CMSG_* macros from sys/sockets.h
+ [[ ${CHOST} == *-solaris* ]] && append-cflags "-D_XOPEN_SOURCE=600"
+
+ # localstatedir for nsupdate -l, bug 395785
+ tc-export BUILD_CC
+ econf "${myeconfargs[@]}"
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ local AR=$(tc-getAR)
+
+ emake AR="${AR}" -C lib/
+ emake AR="${AR}" -C bin/delv/
+ emake AR="${AR}" -C bin/dig/
+ emake AR="${AR}" -C bin/nsupdate/
+ emake AR="${AR}" -C bin/dnssec/
+ emake -C doc/man/ man $(usev doc)
+}
+
+src_install() {
+ local man_dir="${S}/doc/man"
+ local html_dir="${man_dir}/_build/html"
+
+ dodoc README CHANGES
+
+ cd "${S}"/bin/delv || die
+ dobin delv
+ doman ${man_dir}/delv.1
+
+ cd "${S}"/bin/dig || die
+ dobin dig host nslookup
+ doman ${man_dir}/{dig,host,nslookup}.1
+
+ cd "${S}"/bin/nsupdate || die
+ dobin nsupdate
+ doman ${man_dir}/nsupdate.1
+ if use doc; then
+ docinto html
+ dodoc ${html_dir}/nsupdate.html
+ fi
+
+ cd "${S}"/bin/dnssec || die
+ for tool in dsfromkey importkey keyfromlabel keygen \
+ revoke settime signzone verify; do
+ dobin dnssec-"${tool}"
+ doman ${man_dir}/dnssec-"${tool}".8
+ if use doc; then
+ docinto html
+ dodoc ${html_dir}/dnssec-"${tool}".html
+ fi
+ done
+}