summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-09 16:24:38 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-03-09 16:24:38 -0800
commit537bd5f5dea823e71d408e31f1c839891fc8b294 (patch)
tree6b6ffc085307e00b0a72386fedfdbff893c39121
parentsys-libs/pam_wrapper: depend on newer PAM (non split-usr) (diff)
downloadgentoo-537bd5f5dea823e71d408e31f1c839891fc8b294.tar.gz
gentoo-537bd5f5dea823e71d408e31f1c839891fc8b294.tar.bz2
gentoo-537bd5f5dea823e71d408e31f1c839891fc8b294.zip
app-text/lowdown: Version bump to 0.11.1 (fix #832797)
Closes: https://bugs.gentoo.org/832797 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/files/lowdown-0.11.1-linking.patch33
-rw-r--r--app-text/lowdown/lowdown-0.11.1.ebuild45
3 files changed, 79 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
index e1d3afdf8827..0a116aa9f30c 100644
--- a/app-text/lowdown/Manifest
+++ b/app-text/lowdown/Manifest
@@ -1,2 +1,3 @@
DIST lowdown-0.10.0.tar.gz 547397 BLAKE2B 93d87e3aca2466398a625750b928062fbafd26311899e52ddd8264218675e78d30714c920f3331619fcd510a92cc6046401c946f5bd1465d6fd46f26937318ac SHA512 7454e618607628ec0a1649f44f5ec64f8778ecaa151f6aad4984935e297abfe8e84ffc321d3c93cec5d336ff14b6bf9a0ff9054e7363cc58ba708a5b60db9048
+DIST lowdown-0.11.1.tar.gz 571320 BLAKE2B 28fe8cb4f164618be602770c602f3ce51c0f0e765fb9869b82cb29c50bdbe0fd92c09c10074d8968108eca59096d7e176531eb56cb2b40f1d9c00a3f944e3b8c SHA512 5a8ca9d731171b97daed7a9095bc4206d2bed9095fa267eb9270782770247743f1a096c5235fd301320418c37a478fbc71552ade105eba0e756ff687835d4efb
DIST lowdown-0.8.4.tar.gz 520735 BLAKE2B dc66b92f285b186ca83b9fad1cccfef9b395233ef56756e9ea9071b5502cd81dc6ce2d67d7ef265dab8953010af0907cd76125cd4442cfbfc2bcf8c63e097809 SHA512 cd46ead69ed038bf3ccf848b784327d66c78dd8adbc9ae4bfee660b9b1e52844ac8c7ad0377f8f38a3fee0d2e523f979a22d6b547c7964304accef0951cfca34
diff --git a/app-text/lowdown/files/lowdown-0.11.1-linking.patch b/app-text/lowdown/files/lowdown-0.11.1-linking.patch
new file mode 100644
index 000000000000..89595d54fb02
--- /dev/null
+++ b/app-text/lowdown/files/lowdown-0.11.1-linking.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 7705432..4208e47 100644
+--- a/Makefile
++++ b/Makefile
+@@ -173,8 +173,8 @@ installwww: www
+ $(INSTALL) -m 0444 lowdown.tar.gz $(WWWDIR)/snapshots
+ $(INSTALL) -m 0444 lowdown.tar.gz.sha512 $(WWWDIR)/snapshots
+
+-lowdown: liblowdown.a main.o
+- $(CC) -o $@ main.o liblowdown.a $(LDFLAGS) $(LDADD_MD5) -lm
++lowdown: liblowdown.so main.o
++ $(CC) -o $@ main.o $(LDADD_MD5) -lm -llowdown $(LDFLAGS)
+
+ lowdown-diff: lowdown
+ ln -f lowdown lowdown-diff
+@@ -183,7 +183,7 @@ liblowdown.a: $(OBJS) $(COMPAT_OBJS)
+ $(AR) rs $@ $(OBJS) $(COMPAT_OBJS)
+
+ liblowdown.so: $(OBJS) $(COMPAT_OBJS)
+- $(CC) -shared -o $@.$(LIBVER) $(OBJS) $(COMPAT_OBJS) $(LDFLAGS) $(LDADD_MD5) -Wl,-soname,$@.$(LIBVER)
++ $(CC) -shared -o $@.$(LIBVER) $(OBJS) $(COMPAT_OBJS) $(LDFLAGS) $(LDADD_MD5) -lm -Wl,-soname,$@.$(LIBVER)
+ ln -sf $@.$(LIBVER) $@
+
+ install: bins
+@@ -218,7 +218,7 @@ install_shared: liblowdown.so install_lib_common
+ install_static: liblowdown.a install_lib_common
+ $(INSTALL_LIB) liblowdown.a $(DESTDIR)$(LIBDIR)
+
+-install_libs: install_shared install_static
++install_libs: install_shared
+
+ distcheck: lowdown.tar.gz.sha512
+ mandoc -Tlint -Werror man/*.[135]
diff --git a/app-text/lowdown/lowdown-0.11.1.ebuild b/app-text/lowdown/lowdown-0.11.1.ebuild
new file mode 100644
index 000000000000..203b145ffc66
--- /dev/null
+++ b/app-text/lowdown/lowdown-0.11.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.10.0-pkgconfig-libmd.patch"
+ "${FILESDIR}/lowdown-0.11.1-linking.patch"
+)
+
+src_configure() {
+ append-flags -fPIC
+ tc-export CC AR
+
+ ./configure \
+ PREFIX="/usr" \
+ MANDIR="/usr/share/man" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LIBDIR="/usr/$(get_libdir)" \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ emake regress
+}