summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-29 12:16:22 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-29 12:39:04 +0200
commit538afbd1c53cf40109c6be036ec28c2cb0ef94bc (patch)
tree01b8a2bb22b8da335b04440f4af0837b74f3c610
parentsys-cluster/neutron: Fix DoublePrefixInPath (diff)
downloadgentoo-538afbd1.tar.gz
gentoo-538afbd1.tar.bz2
gentoo-538afbd1.zip
sys-cluster/nova: Fix DoublePrefixInPath
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-cluster/nova/nova-18.2.2.ebuild4
-rw-r--r--sys-cluster/nova/nova-19.0.2.ebuild4
-rw-r--r--sys-cluster/nova/nova-2018.2.9999.ebuild4
-rw-r--r--sys-cluster/nova/nova-2019.1.9999.ebuild4
4 files changed, 8 insertions, 8 deletions
diff --git a/sys-cluster/nova/nova-18.2.2.ebuild b/sys-cluster/nova/nova-18.2.2.ebuild
index 123609323504..f57c926d0e3e 100644
--- a/sys-cluster/nova/nova-18.2.2.ebuild
+++ b/sys-cluster/nova/nova-18.2.2.ebuild
@@ -242,8 +242,8 @@ python_install_all() {
python_install() {
distutils-r1_python_install
# copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ python_moduleinto db/sqlalchemy/migrate_repo
+ python_domodule nova/db/sqlalchemy/migrate_repo/migrate.cfg
}
pkg_postinst() {
diff --git a/sys-cluster/nova/nova-19.0.2.ebuild b/sys-cluster/nova/nova-19.0.2.ebuild
index ffc81bcc8570..d25e3939bb40 100644
--- a/sys-cluster/nova/nova-19.0.2.ebuild
+++ b/sys-cluster/nova/nova-19.0.2.ebuild
@@ -244,8 +244,8 @@ python_install_all() {
python_install() {
distutils-r1_python_install
# copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ python_moduleinto db/sqlalchemy/migrate_repo
+ python_domodule nova/db/sqlalchemy/migrate_repo/migrate.cfg
}
pkg_postinst() {
diff --git a/sys-cluster/nova/nova-2018.2.9999.ebuild b/sys-cluster/nova/nova-2018.2.9999.ebuild
index f0694e7ed9a0..dd30ccf5b550 100644
--- a/sys-cluster/nova/nova-2018.2.9999.ebuild
+++ b/sys-cluster/nova/nova-2018.2.9999.ebuild
@@ -242,8 +242,8 @@ python_install_all() {
python_install() {
distutils-r1_python_install
# copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ python_moduleinto db/sqlalchemy/migrate_repo
+ python_domodule nova/db/sqlalchemy/migrate_repo/migrate.cfg
}
pkg_postinst() {
diff --git a/sys-cluster/nova/nova-2019.1.9999.ebuild b/sys-cluster/nova/nova-2019.1.9999.ebuild
index a28cdc16dcc1..da689ce9ff46 100644
--- a/sys-cluster/nova/nova-2019.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2019.1.9999.ebuild
@@ -244,8 +244,8 @@ python_install_all() {
python_install() {
distutils-r1_python_install
# copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ python_moduleinto db/sqlalchemy/migrate_repo
+ python_domodule nova/db/sqlalchemy/migrate_repo/migrate.cfg
}
pkg_postinst() {