summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-09-21 10:29:28 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-09-21 11:40:43 +0300
commit538d458f65ead09deb942bc04b672268a0353706 (patch)
treeff03e2be1ca71e34f8ec963d2266434ac6ab3890
parentapp-portage/mgorny-dev-scripts: Bump to v27 (diff)
downloadgentoo-538d458f65ead09deb942bc04b672268a0353706.tar.gz
gentoo-538d458f65ead09deb942bc04b672268a0353706.tar.bz2
gentoo-538d458f65ead09deb942bc04b672268a0353706.zip
www-client/firefox: move the updated addpredict under pgo condition
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-client/firefox/firefox-105.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-105.0.ebuild b/www-client/firefox/firefox-105.0.ebuild
index 9b338e3b7c2e..30bb5fdcd1dd 100644
--- a/www-client/firefox/firefox-105.0.ebuild
+++ b/www-client/firefox/firefox-105.0.ebuild
@@ -481,13 +481,17 @@ pkg_setup() {
XDG_SESSION_COOKIE
# Build system is using /proc/self/oom_score_adj, bug #604394
- # Update 105.0: "/proc/self/oom_score_adj" isn't enough anymore, but not sure whether that's
- # due to better OOM handling by Firefox, or portage (PORTAGE_SCHEDULING_POLICY) update...
- # addpredict /proc/self/oom_score_adj
- addpredict /proc
- # addpredict /dev/dri
+ addpredict /proc/self/oom_score_adj
if use pgo ; then
+ # Update 105.0: "/proc/self/oom_score_adj" isn't enough anymore with pgo, but not sure
+ # whether that's due to better OOM handling by Firefox (bmo#1771712), or portage
+ # (PORTAGE_SCHEDULING_POLICY) update...
+ addpredict /proc
+
+ # May need a wider addpredict when using wayland+pgo.
+ # addpredict /dev/dri
+
# Allow access to GPU during PGO run
local ati_cards mesa_cards nvidia_cards render_cards
shopt -s nullglob