summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucianposton@pm.me>2020-02-14 15:22:56 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-02-27 15:54:43 +0200
commit5396d2d6f7ac6aa024f6f5d68b9c32913c13f3bc (patch)
tree52b11c83c2d339fdf3fed267626b65448863c766
parentdev-util/vint: Add maintainer (diff)
downloadgentoo-5396d2d6.tar.gz
gentoo-5396d2d6.tar.bz2
gentoo-5396d2d6.zip
dev-util/vint: Bump 0.3.21
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lucian Poston <lucianposton@pm.me> Closes: https://github.com/gentoo/gentoo/pull/14661 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-util/vint/Manifest1
-rw-r--r--dev-util/vint/vint-0.3.21.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
index 25608badb872..b146fad7a21d 100644
--- a/dev-util/vint/Manifest
+++ b/dev-util/vint/Manifest
@@ -1,2 +1,3 @@
DIST vint-0.3.18.tar.gz 95865 BLAKE2B 0f7e61b720aa0998091b9b40118b199392fbf1aeace8801d683e8249179cd3d792e15b42df6d34c567c4df1830629a80e6043e87092f37dc46a0e57c6a56cf53 SHA512 1d3e04527a8f5ffae29395010a88258c1771aff2798143eff6572400eaf96323cad04353a7fcee68d9407afde5808446f515fd3d7e8e62de4bef28edf214ebdd
DIST vint-0.3.19.tar.gz 96755 BLAKE2B 0b03807a4286b3e030e00c112dd0e879fa39e0d2333d46ea159555de50b30098d9a8b2345da8e18b7e1e5c814f10678df2e64398a615bf381186faa0036939f5 SHA512 b9024ed1cd8a18a916798e691ba0db31985034b2420e33c094459a48254c7c8f6fe89a1a64858a67ff95b0b48e67a780cf975940646af2685d2b95640e8121f9
+DIST vint-0.3.21.tar.gz 96747 BLAKE2B 926b46493030dc0daa477ded3cb70f2b825b4eb8054c14a4b824b97e7df60d0141cf1bcf4c33893afd870f51308b7156fb6e5870f320f8c9449fdca8fe78774f SHA512 47e832d382952cb16bcc233eefa1f06ca74f95eb445d7f96d6804391b91a2c8a8e7b749b7f33f65aed9d3bdc1ff5e5332a62c3935969395f16a854f0f66e383b
diff --git a/dev-util/vint/vint-0.3.21.ebuild b/dev-util/vint/vint-0.3.21.ebuild
new file mode 100644
index 000000000000..fa27da44ce3c
--- /dev/null
+++ b/dev-util/vint/vint-0.3.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.org/project/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Tests fail due to python 3.8 warnings in stderr that appear when
+ # compiled byte code is disabled
+ # https://github.com/Vimjas/vint/issues/355
+ [[ "${EPYTHON}" == python3.8 ]] && return
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}