summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-12 15:39:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-12 15:40:09 +0200
commit53af3472a366dea712679776e7d8c5d0d8f30a3b (patch)
tree1951fccf2fb45bd73e6fb0697cad64929da090b1
parentapp-vim/ackvim: Add ack to DEPEND/RDEPEND. (diff)
downloadgentoo-53af3472a366dea712679776e7d8c5d0d8f30a3b.tar.gz
gentoo-53af3472a366dea712679776e7d8c5d0d8f30a3b.tar.bz2
gentoo-53af3472a366dea712679776e7d8c5d0d8f30a3b.zip
media-sound/qsynth: bump to 0.4.1
Package-Manager: portage-2.2.28
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.4.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 9e63c3b7d3de..eab53f087075 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,3 +1,4 @@
DIST qsynth-0.3.6.tar.gz 223774 SHA256 b5968da98661bac5c9fcc93d3a15851594dfbf3bb7d01ace15fbe8779d53fb3c SHA512 c61f6913f28a18a8e74af290560c0f8862e86c192715299fd24e73243a3563c1d65bebf6ab8844c692b06bf357f6bf42d43ef5298d74636fe7c4c082aea3eeea WHIRLPOOL 0e3c6aaab8a4ed9a77baca128f4661c4dfd82d089b636d3ce97a95ce4a303ba745f5023447bd1d5477aeda4bad5b64923f69e3aa1d5a1e435b5efb7906829483
DIST qsynth-0.3.9.tar.gz 255130 SHA256 eb2050d0f7a8011b9ac20f82fec88faf2237a2475dfefc424cb4944399b17e22 SHA512 7702dc9eb3d38d338dcab5587e02e9fcdaffbe6188437e3b0f54b07499553f7a7d083f233cd21963a908578108f82c0d904b68da2f156ca0ab489e989b5787a8 WHIRLPOOL 621b53fbf251e4b35dcdefb6b63e6ed124fc12dccad6148f077914bd25931cc8ea10a8dfb959b5ad4ae8a451686c63dedeb060b8a68d7a3d6e72e2d5c437104a
DIST qsynth-0.4.0.tar.gz 251230 SHA256 9dc8413ddc6847a2dd0bfb3b44e0246273531ea253fd9dc91c5c329876420cb2 SHA512 13d8cda192ae09a3e48768df11d2df7ccace59a495f18bd99d6b7009c51eb43b3d6df97e81391e9c098c6fdc0396434bf178302edb016bdba69d6aa4d790a831 WHIRLPOOL 8f5873874018e538767ea44bf8752adc11e5e993a26b71beb0b54a3739d2ed9b5fed042f9af1925d45b9fdc6fed74ecebdd19164ab2d9cdc5d43831aeda1f503
+DIST qsynth-0.4.1.tar.gz 251821 SHA256 50f4e36e0c5a7e092429e1cafbd8989346127b8b0c0868566addcacc5735970c SHA512 0a4e2dacc9116a9c52a50af39f0838a0c97d0e2f0ba75f8c3f07a219810299c5dd650ad7cd5ba337e497f83537b7cb94a181c9e3a5ba641febe1a0179d6c8620 WHIRLPOOL 044811f6a2966cfccd613da8db16d8caa46599d61fbdf8124d94c57d25b796155fa76261cb3bed7fbb49f8cd7d4eaaa9bb1e2966db97236be61f98121f43c453
diff --git a/media-sound/qsynth/qsynth-0.4.1.ebuild b/media-sound/qsynth/qsynth-0.4.1.ebuild
new file mode 100644
index 000000000000..de76b60334de
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.4.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils eutils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug jack alsa pulseaudio +qt5"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ qt5? (
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtcore:5
+ )
+ !qt5? (
+ >=dev-qt/qtcore-4.2:4
+ >=dev-qt/qtgui-4.2:4
+ )
+ >=media-sound/fluidsynth-1.0.7a[jack?,alsa?,pulseaudio?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+src_prepare() {
+ use qt5 && epatch "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable qt5) \
+ --with-qt"$(usex qt5 "5=$(qt5_get_bindir)/.." "4=$(qt4_get_bindir)/..")"
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ if use qt5 ; then
+ eqmake5 ${PN}.pro -o ${PN}.mak
+ else
+ eqmake4 ${PN}.pro -o ${PN}.mak
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+
+ dodoc AUTHORS ChangeLog README TODO TRANSLATORS
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}