summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-28 04:38:19 +0000
committerSam James <sam@gentoo.org>2024-03-28 04:38:19 +0000
commit53dafe0e2cac1f90db36d0c5c00572a73308ec50 (patch)
tree06716f1c8f06956c66d537d8e744023a52b040ad
parentnet-misc/streamlink: drop 6.7.0, 6.7.1 (diff)
downloadgentoo-53dafe0e2cac1f90db36d0c5c00572a73308ec50.tar.gz
gentoo-53dafe0e2cac1f90db36d0c5c00572a73308ec50.tar.bz2
gentoo-53dafe0e2cac1f90db36d0c5c00572a73308ec50.zip
sys-apps/irqbalance: add 1.9.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/irqbalance/Manifest1
-rw-r--r--sys-apps/irqbalance/irqbalance-1.9.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/Manifest b/sys-apps/irqbalance/Manifest
index 25665968bffd..8abb73f52915 100644
--- a/sys-apps/irqbalance/Manifest
+++ b/sys-apps/irqbalance/Manifest
@@ -1 +1,2 @@
DIST irqbalance-1.9.3.tar.gz 62573 BLAKE2B 0f7b3b62c3784c009c6829078cdf5496910ec3f3c8c13de5f0dfbaed510fb5e3dab4953810c646ece962ef130af3aaa0bb9fa8c2e013485751cc661c9458e87a SHA512 5638fb59f5a59901333b90289ee70c960df0e2b9e55731805397797b8e630bb3703e36a4dfd05bf01de49334dab9d6fc95bde4967eeab131534950d281103fa1
+DIST irqbalance-1.9.4.tar.gz 63005 BLAKE2B 6b8bf28e11686713ca9c00a1b98c5f3afb38c26e919a9d7de126145d12c4e8e23e8ea00b2534bb0339e5990ed5cb642291df975ba9868835e9c4e8a23c98f2ef SHA512 abdcac9dccabb18ae644b73dc2a8528c03279811c1f9182a5a5b0af43b30c5982d7bb14e79d4430b5d4f2cea8e17115e6038851c74de1ff3bdfc4e303392479a
diff --git a/sys-apps/irqbalance/irqbalance-1.9.4.ebuild b/sys-apps/irqbalance/irqbalance-1.9.4.ebuild
new file mode 100644
index 000000000000..b1912f7864a0
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.9.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev systemd linux-info optfeature
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="caps +numa systemd selinux thermal tui"
+# Hangs
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+ systemd? ( sys-apps/systemd:= )
+ thermal? ( dev-libs/libnl:3 )
+ tui? ( sys-libs/ncurses:=[unicode(+)] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ # Follow systemd policies
+ # https://wiki.gentoo.org/wiki/Project:Systemd/Ebuild_policy
+ sed \
+ -e 's/ $IRQBALANCE_ARGS//' \
+ -e '/EnvironmentFile/d' \
+ -i misc/irqbalance.service || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ $(use_with systemd)
+ $(use_enable thermal)
+ $(use_with tui irqbalance-ui)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/irqbalance.init.4 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit misc/irqbalance.service
+ udev_dorules misc/90-irqbalance.rules
+}
+
+pkg_postinst() {
+ optfeature "thermal events support (requires USE=thermal)" sys-power/thermald
+}