summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 07:02:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 08:26:54 +0100
commit53f57c92a001b7da60f9709f0a6bace701dc0849 (patch)
treed01de07cedbd8581251812ab95ce4068f41efb2c
parentdev-python/exceptiongroup: Bump to 1.0.3 (diff)
downloadgentoo-53f57c92.tar.gz
gentoo-53f57c92.tar.bz2
gentoo-53f57c92.zip
dev-python/ini2toml: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/ini2toml-0.11.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index 523eea28e797..5a46ee3db533 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1 +1,2 @@
+DIST ini2toml-0.11.1.gh.tar.gz 93986 BLAKE2B ec5cd963626b5391663b782ba8c32996f6d172e034eb1f9476da0336ebd3dc5d2244fe72a039bb121182e85df798da37dfc391a52808e9e8a9e84d3c5e1889a0 SHA512 5229072e5ebaffb1c2efd16f58f72c562fd1ca73d3ce46dccc80672085301f9d35460796f8ac4118ea37f970e45d4e4d4efd3da8e4a88c6a696f1e8b644cf1cd
DIST ini2toml-0.11.gh.tar.gz 93696 BLAKE2B 0fb52b346065421049fd377a62de4189a6d261ad12c00679c97568a0e7b7f8fc7bf1aae2196b8fc70489d547c0ce9be1347336d25769c7fb383f9fec4d4aa205 SHA512 7329fd3ba31567638fffce22f2370c2055503bd4abc3d7dab30b1828eb54204d31036753efddfab52e79703ce7583f6070e1207c95345096c0751c2d429fd6ea
diff --git a/dev-python/ini2toml/ini2toml-0.11.1.ebuild b/dev-python/ini2toml/ini2toml-0.11.1.ebuild
new file mode 100644
index 000000000000..e5f2a01f36bb
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.11.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+SRC_URI="
+ https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ dev-python/pyproject-fmt[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}