summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.website>2023-12-03 14:13:28 +0530
committerSam James <sam@gentoo.org>2023-12-03 09:12:04 +0000
commit53f58249ab6783ab39c691f65d637a09dcd5e84a (patch)
tree4f0ac8ec408d6ecd14f1e3aa2f32cdfd4f4b6794
parentdev-java/commons-collections: minor style update (slot 4) (diff)
downloadgentoo-53f58249ab6783ab39c691f65d637a09dcd5e84a.tar.gz
gentoo-53f58249ab6783ab39c691f65d637a09dcd5e84a.tar.bz2
gentoo-53f58249ab6783ab39c691f65d637a09dcd5e84a.zip
app-containers/skopeo: revbump 1.14.0
1. Use einstalldocs instead of manual dodoc 2. fix build error caused by device-mapper introduced in 1.14.0-r2 https://github.com/containers/skopeo/pull/2161 Closes: https://bugs.gentoo.org/919074 Signed-off-by: Rahil Bhimjiani <me@rahil.website> Closes: https://github.com/gentoo/gentoo/pull/34103 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-containers/skopeo/skopeo-1.14.0-r3.ebuild (renamed from app-containers/skopeo/skopeo-1.14.0-r2.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-containers/skopeo/skopeo-1.14.0-r2.ebuild b/app-containers/skopeo/skopeo-1.14.0-r3.ebuild
index 2aed06a521af..445d403f11a9 100644
--- a/app-containers/skopeo/skopeo-1.14.0-r2.ebuild
+++ b/app-containers/skopeo/skopeo-1.14.0-r3.ebuild
@@ -49,8 +49,8 @@ run_make() {
emake \
BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
- LIBDM_BUILD_TAG=$(usex device-mapper '' libdm_no_deferred_remove) \
- LIBSUBID_BUILD_TAG=$(usex rootless 'libsubid' '') \
+ LIBDM_BUILD_TAG="$(usex device-mapper '' 'libdm_no_deferred_remove exclude_graphdriver_devicemapper')" \
+ LIBSUBID_BUILD_TAG="$(usex rootless 'libsubid' '')" \
PREFIX="${EPREFIX}/usr" \
$@
}
@@ -63,7 +63,7 @@ src_install() {
# The install target in the Makefile tries to rebuild the binary and
# installs things that are already installed by containers-common.
dobin bin/skopeo
-dodoc README.md
+ einstalldocs
doman docs/*.1
run_make "DESTDIR=${D}" install-completions
}