summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-03-09 17:47:10 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-10 13:16:25 +0100
commit5401a0bca754883a3466da1c35ccabab423190ee (patch)
treecb2efc791b73f1c3792c9d9775a0d93f1d2dcab4
parentprofiles: mask sci-physics/root[R] (diff)
downloadgentoo-5401a0bca754883a3466da1c35ccabab423190ee.tar.gz
gentoo-5401a0bca754883a3466da1c35ccabab423190ee.tar.bz2
gentoo-5401a0bca754883a3466da1c35ccabab423190ee.zip
sci-physics/root: filter lto flags, bug #879323
Closes: https://bugs.gentoo.org/879323 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--sci-physics/root/root-6.28.12.ebuild5
-rw-r--r--sci-physics/root/root-6.30.04.ebuild5
-rw-r--r--sci-physics/root/root-6.30.9999.ebuild7
-rw-r--r--sci-physics/root/root-9999.ebuild7
4 files changed, 18 insertions, 6 deletions
diff --git a/sci-physics/root/root-6.28.12.ebuild b/sci-physics/root/root-6.28.12.ebuild
index 5f308e286c0a..47324a37ee7d 100644
--- a/sci-physics/root/root-6.28.12.ebuild
+++ b/sci-physics/root/root-6.28.12.ebuild
@@ -8,7 +8,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
+inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
@@ -168,6 +168,9 @@ src_prepare() {
# with vanilla clang. The patches enable the C++ interpreter to work.
src_configure() {
+
+ filter-lto # https://bugs.gentoo.org/879323
+
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"
diff --git a/sci-physics/root/root-6.30.04.ebuild b/sci-physics/root/root-6.30.04.ebuild
index 5f308e286c0a..47324a37ee7d 100644
--- a/sci-physics/root/root-6.30.04.ebuild
+++ b/sci-physics/root/root-6.30.04.ebuild
@@ -8,7 +8,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
+inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
@@ -168,6 +168,9 @@ src_prepare() {
# with vanilla clang. The patches enable the C++ interpreter to work.
src_configure() {
+
+ filter-lto # https://bugs.gentoo.org/879323
+
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"
diff --git a/sci-physics/root/root-6.30.9999.ebuild b/sci-physics/root/root-6.30.9999.ebuild
index 831e28f81da0..47324a37ee7d 100644
--- a/sci-physics/root/root-6.30.9999.ebuild
+++ b/sci-physics/root/root-6.30.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
+inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
@@ -168,6 +168,9 @@ src_prepare() {
# with vanilla clang. The patches enable the C++ interpreter to work.
src_configure() {
+
+ filter-lto # https://bugs.gentoo.org/879323
+
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 831e28f81da0..47324a37ee7d 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake cuda fortran-2 python-single-r1 toolchain-funcs
+inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
@@ -168,6 +168,9 @@ src_prepare() {
# with vanilla clang. The patches enable the C++ interpreter to work.
src_configure() {
+
+ filter-lto # https://bugs.gentoo.org/879323
+
local mycmakeargs=(
-DCMAKE_C_COMPILER="$(tc-getCC)"
-DCMAKE_CXX_COMPILER="$(tc-getCXX)"