summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-13 08:29:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-13 08:34:59 +0200
commit5406ad3f3c2ea1dc13e5733d8ab0adf697a84239 (patch)
tree57e51b066e42f237dcc328aad48ae7fab8952830
parentdev-python/micawber: Bump to 0.5.4 (diff)
downloadgentoo-5406ad3f3c2ea1dc13e5733d8ab0adf697a84239.tar.gz
gentoo-5406ad3f3c2ea1dc13e5733d8ab0adf697a84239.tar.bz2
gentoo-5406ad3f3c2ea1dc13e5733d8ab0adf697a84239.zip
dev-python/tenacity: Bump to 8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 615a34b4522f..99961be7e11f 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1,2 +1,3 @@
DIST tenacity-7.0.0.tar.gz 33874 BLAKE2B 485b35058e246ac7c68a2d92a4bd30ae182d382d4258854afb1e61d0b31cd1674bfd92599b83425f4e9a92ca4c38e4a91b72a17d0de6f918474ebe59e6bd2d66 SHA512 a627112df19b9f6d1c53294daad7fe1b0aeaed15e6ec07054228575fbc76ca5c22f560ddd6fc176c5c22141669423547ba17f1e33c7d0e7e92d0188acad065c4
DIST tenacity-8.0.0.tar.gz 35483 BLAKE2B bde48a9682d1ce661ec6a35387c8a3931e60f61ac605b95637ce88176a5346eed54047623d0ee116e5c6d279f265d9cee0fd69e2b805c50cd7e06390d6952813 SHA512 f9c8b74d53dc4973e833a2d2625d15b7f40b813b1cfe389511c1083e738d62b0793dbfab73ed13a9e88cc65a17d2c6d8b0a571f13732a26f4c957e16dd9bbefc
+DIST tenacity-8.0.1.tar.gz 37492 BLAKE2B 10438b3877862baa88d164837b201773c287e7ce11b6213c677c227cbddda02434b423c0f331746495e68ab130ff9a9c720cccd2def3efa8ca6df8eef441eee9 SHA512 b5a615306e25c93d2734d408cc73f4db5361d92b713c1e7bbb57cd7bf635f82c5ccffafe9c0a6bc0da4057d11c92012d2337a5e4f15465bf4e6839d1fa97b877
diff --git a/dev-python/tenacity/tenacity-8.0.1.ebuild b/dev-python/tenacity/tenacity-8.0.1.ebuild
new file mode 100644
index 000000000000..4d837bd1e2de
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/jd/tenacity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO: package typeguard
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}