summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 23:16:40 +0000
committerSam James <sam@gentoo.org>2022-11-19 23:37:07 +0000
commit540b27fe154c9355fe138d21fa7fc82549a3a055 (patch)
treeb0e54c2d8a706d518bb4d287a305e9ece9aec4df
parentx11-libs/libXpm: Version bump to 3.5.14 (diff)
downloadgentoo-540b27fe154c9355fe138d21fa7fc82549a3a055.tar.gz
gentoo-540b27fe154c9355fe138d21fa7fc82549a3a055.tar.bz2
gentoo-540b27fe154c9355fe138d21fa7fc82549a3a055.zip
mail-filter/spamassassin: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mail-filter/spamassassin/files/3.4.6-configure-clang16.patch44
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.6-r2.ebuild (renamed from mail-filter/spamassassin/spamassassin-3.4.6-r1.ebuild)3
2 files changed, 46 insertions, 1 deletions
diff --git a/mail-filter/spamassassin/files/3.4.6-configure-clang16.patch b/mail-filter/spamassassin/files/3.4.6-configure-clang16.patch
new file mode 100644
index 000000000000..cd69a546c71d
--- /dev/null
+++ b/mail-filter/spamassassin/files/3.4.6-configure-clang16.patch
@@ -0,0 +1,44 @@
+https://bz.apache.org/SpamAssassin/show_bug.cgi?id=8073
+--- a/spamc/configure.in
++++ b/spamc/configure.in
+@@ -48,7 +48,9 @@ dnl ----------------------------------------------------------------------
+ AC_CACHE_CHECK([for SHUT_RD],
+ shutrd, [
+ AC_TRY_COMPILE([#include <sys/types.h>
+-#include <sys/socket.h>],
++#include <sys/socket.h>
++#include <stdio.h>
++],
+ [printf ("%d", SHUT_RD); return 0;],
+ [shutrd=yes],
+ [shutrd=no]),
+@@ -89,7 +91,8 @@ dnl ----------------------------------------------------------------------
+
+ AC_CACHE_CHECK([for h_errno],
+ herrno, [
+- AC_TRY_COMPILE([#include <netdb.h>],
++ AC_TRY_COMPILE([#include <netdb.h>
++#include <stdio.h>],
+ [printf ("%d", h_errno); return 0;],
+ [herrno=yes],
+ [herrno=no]),
+diff --git a/spamc/configure b/spamc/configure
+index d8e5dcf..2e30ba4 100755
+--- a/spamc/configure
++++ b/spamc/configure
+@@ -3555,6 +3555,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <stdio.h>
+ int
+ main ()
+ {
+@@ -4253,6 +4254,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <netdb.h>
++#include <stdio.h>
+ int
+ main ()
+ {
diff --git a/mail-filter/spamassassin/spamassassin-3.4.6-r1.ebuild b/mail-filter/spamassassin/spamassassin-3.4.6-r2.ebuild
index dccfae5da460..eead64d35fa0 100644
--- a/mail-filter/spamassassin/spamassassin-3.4.6-r1.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.4.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -82,6 +82,7 @@ RDEPEND="${REQDEPEND} ${OPTDEPEND}"
PATCHES=(
"${FILESDIR}/mention-geoip.cf-in-init.pre.patch"
+ "${FILESDIR}/3.4.6-configure-clang16.patch"
)
# There are a few renames and use-dependent ones in src_istall as well.