summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-22 00:54:00 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-22 02:03:27 +0100
commit5410241446e390b73e6c0b3653067c0d73628dc6 (patch)
treea58c48b620a10a0105bc69525af71d90c40db307
parentsci-electronics/nvc: bump to 1.11.1 (diff)
downloadgentoo-5410241446e390b73e6c0b3653067c0d73628dc6.tar.gz
gentoo-5410241446e390b73e6c0b3653067c0d73628dc6.tar.bz2
gentoo-5410241446e390b73e6c0b3653067c0d73628dc6.zip
app-containers/devcontainer: bump to 0.55.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.55.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index cac09ef91977..2ca94d230278 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1 +1,2 @@
DIST devcontainer-0.54.2.tgz 603920 BLAKE2B 85737eccc793da9454fb2e8069f843356781606ce8fbfeedf1f04bf1d012f5f1ec70b1e6fd200fc2d43fa28f3b8a9647e05f42a42096dbaf6cab95a410cb6df9 SHA512 4d5e0f8be0dd3ff9b755037e489f86aeab40bc1b1ba3a558e9be5ae89ab7f109874ca04082e6851d3fe1fca2fd4f8d8c09df8e6bed273de2719e5784f30ca71c
+DIST devcontainer-0.55.0.tgz 604221 BLAKE2B e369e20b19dc780f7543f409ac04a46f432a9c007d4976dcb34829ede883424fb9496f6b7a50d047665fd4cba4b45c7ae1bc3372720f0b1dc65a8085d06a9287 SHA512 53bc02b7cdb04f7901f3c74d0a26d466231f4bc7f0e53de25c786a9ecb3b774a09b14e47e36470538560893fc6c7ec6bf9b19345e0d6bf0ff3b9db329f21e8cd
diff --git a/app-containers/devcontainer/devcontainer-0.55.0.ebuild b/app-containers/devcontainer/devcontainer-0.55.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.55.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}