summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-29 06:07:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-29 06:07:41 +0100
commit54123ce3d9a902c9f6d1d2324469c2597190f587 (patch)
tree2cf4965725526d7943ef7effb09227cfe418b9f4
parentdev-python/sqlglot: Bump to 23.3.0 (diff)
downloadgentoo-54123ce3d9a902c9f6d1d2324469c2597190f587.tar.gz
gentoo-54123ce3d9a902c9f6d1d2324469c2597190f587.tar.bz2
gentoo-54123ce3d9a902c9f6d1d2324469c2597190f587.zip
dev-python/requests-mock: Bump to 1.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-mock/Manifest1
-rw-r--r--dev-python/requests-mock/requests-mock-1.12.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index 04f30c1c24c8..0f27f91b764d 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,2 +1,3 @@
DIST requests-mock-1.11.0.tar.gz 74377 BLAKE2B f871bbd18b42668d9eb693b807a67a33c9fb7c4316966ad2c16800bf562be982c737e1c1a803e3c5b6d3cde8c3d789671b5fce7d54df308dc55b2ef73a641ff4 SHA512 8d161cb0f6183994053d4dd06b801c2614b7ac937798addcdc52ee8e3973a7ef874ca615ca1946ea4bc0e05ce36c5c813460f7a41b3254671095059536fd2961
DIST requests-mock-1.12.0.tar.gz 60874 BLAKE2B 53e0cf6cf25dbfec87e913a9f85c9ad0757e3b071e4c1d66a31810283cd0332a0a8b8317a9da433a2b36f629ff52808a82993126a5f7a9d138c47099072329a3 SHA512 1bc07b5fa90752d73e05de7147f891600fce3041f6b9aaf3ad6be87532b314543340d94087e834801761a7f3aefb0bb1e1bdb717c11b90b940cccf37b2982164
+DIST requests-mock-1.12.1.tar.gz 60901 BLAKE2B 708b19731260b8a1c1334b564c35825a9bceb20b8205ed3ad0f9c778e2c22e3ae4a93fa09cd47e9c745f5a282ebaf83a43be09ee4bd578195b77f69b116e28c6 SHA512 be1f4afa800811025e3c7b14a65759851ef2d56a3e4bf155368dc6772440fe0fcc5d01f62b1b029d0cabd7a57fe35074e3ba0791240f95f43b62109a00f96120
diff --git a/dev-python/requests-mock/requests-mock-1.12.1.ebuild b/dev-python/requests-mock/requests-mock-1.12.1.ebuild
new file mode 100644
index 000000000000..bb051e0ee3b9
--- /dev/null
+++ b/dev-python/requests-mock/requests-mock-1.12.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="
+ https://github.com/jamielennox/requests-mock/
+ https://pypi.org/project/requests-mock/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests-futures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/jamielennox/requests-mock/pull/255
+ "${FILESDIR}/${PN}-1.12.0-no-pbr.patch"
+ )
+
+ # Disable reno which only works inside a git repository
+ sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+ # Remove the release notes section which requires reno
+ rm doc/source/release-notes.rst || die
+ sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+ # Disable a test which requires purl (not in the tree)
+ sed -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+ -i tests/test_adapter.py || die
+ distutils-r1_python_prepare_all
+}