summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-02-17 10:36:46 -0500
committerYixun Lan <dlan@gentoo.org>2024-02-18 08:56:41 +0000
commit542237d50e54e05b6b339ed85f56ed22f19e0d0d (patch)
tree3f57881889aed16869e56a6f9d408bb229b00262
parentapp-arch/lzip: Stabilize 1.24 x86, #924782 (diff)
downloadgentoo-542237d50e54e05b6b339ed85f56ed22f19e0d0d.tar.gz
gentoo-542237d50e54e05b6b339ed85f56ed22f19e0d0d.tar.bz2
gentoo-542237d50e54e05b6b339ed85f56ed22f19e0d0d.zip
gui-wm/hyprland: add 0.35.0
Bug: https://bugs.gentoo.org/923995 Closes: https://bugs.gentoo.org/924179 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.35.0.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 236982f3bf04..da1fb0c0cadf 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,4 @@
DIST hyprland-0.32.3.gh.tar.gz 14119304 BLAKE2B 304878a3bb167da9ceae8afbde21bf2c64b81ffd61c13ccfd772f240d234bb9cbd448f7ae2d0fcc6d8e7c7e29e1eca66ad68d98cfef9b22caccae9ee9f3ae39d SHA512 521cfa6b3621142cb4cc1e6c11978e49f28b29836a1a8e00cc2c697f44dcf620da63e9d39deeabb41130a56c65464b6117416c8a3c1bd690bb056955b7ccea40
DIST hyprland-0.33.1.gh.tar.gz 14120494 BLAKE2B bd007d332b39b614aefe09b240a340ee9d9eed346bc80dc66e976cf2fbf85ca342fe8bd66b863f1626be7366b9623c4543957f0618c858cec133ee9dd6ac027e SHA512 7e45266310452a12ada4761a9b76a7a385e55f6fae6a446c78595e89fcb8b1cef8275e09bf3b9b636a096498c5c2328b1d00b0c33447ab4d018a9a6956855352
DIST hyprland-0.34.0.gh.tar.gz 14128415 BLAKE2B 059fc8b849daeb71b08d7114fd8aea1264c0e9967f471df66b27aca46b95fd499d2929730ba66981bb7d6c423479533b280839db7839ca1df007825f72fb9bf8 SHA512 35cce0668a13d7e7fd220d62efd965a069ff0213996bfa47ca0852c6258881bc070020d4831364b325b71d8ce7373d1793a89006a4341088dcbaf01914920f1a
+DIST hyprland-0.35.0.gh.tar.gz 54200453 BLAKE2B f5a8a5ed5f5ca28e5fc5a329d5191abce458b9bf0b99bee970aaa4be40671bfe945dabe2b3ff34ca753beeb35ec7fe016e6a54669dbe1ee4f25e2c128c3e390d SHA512 5afe7c340b994f2542982d8c8fa837b2a43ef9e487810fec0b33e4a5cc9188b71e41a0be22839191cf15e9c1fdfd964d0751def51f93db438e4a45649077c8a7
diff --git a/gui-wm/hyprland/hyprland-0.35.0.ebuild b/gui-wm/hyprland/hyprland-0.35.0.ebuild
new file mode 100644
index 000000000000..640be8a77ac9
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.35.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ dev-build/meson
+ dev-vcs/git
+ sys-auth/polkit
+ virtual/pkgconfig
+"
+# bundled wlroots has the following dependency string according to included headers.
+# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
+# enable x11-backend with X and vice versa
+WLROOTS_RDEPEND="
+ >=dev-libs/libinput-1.14.0:=
+ dev-libs/libliftoff
+ >=dev-libs/wayland-1.22
+ media-libs/libdisplay-info
+ media-libs/libglvnd
+ media-libs/mesa[egl(+),gles2]
+ sys-apps/hwdata:=
+ sys-auth/seatd:=
+ >=x11-libs/libdrm-2.4.120
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ virtual/libudev:=
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+"
+WLROOTS_DEPEND="
+ >=dev-libs/wayland-protocols-1.32
+"
+WLROOTS_BDEPEND="
+ dev-util/glslang
+ dev-util/wayland-scanner
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ ${WLROOTS_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ dev-libs/wayland
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ X? (
+ x11-libs/libxcb:0=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ${WLROOTS_DEPEND}
+ dev-libs/hyprland-protocols
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ ${WLROOTS_BDEPEND}
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ app-misc/jq
+ dev-build/cmake
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ $(meson_feature X wlroots:xwayland)
+ -Dwlroots:backends=drm,libinput$(usev X ',x11')
+ -Dwlroots:xcb-errors=disabled
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ # First install everything except wlroots to avoid conflicts.
+ meson_src_install --skip-subprojects wlroots
+ # Then install development files (mainly wlroots) for bug #916760.
+ meson_src_install --tags devel
+
+ # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
+ # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
+ # Ideally you could override includedir per subproject and the install tags would
+ # be granular enough to only install headers. But its not requiring this.
+ mkdir "${ED}"/usr/include/hyprland/wlroots || die
+ mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
+ # devel tag includes wlroots .pc and .a files still
+ rm -rf "${ED}"/usr/$(get_libdir)/ || die
+}