summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-10 13:49:53 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-01 15:56:22 +0200
commit543cf8fe6c1fd804dd47a00a56c8f2b81940c37b (patch)
treead22fe2e9847d5e90bec7e5a722b8348e66f0fd8
parentdev-util/lldb: Do not install static libs (in 10.0+) (diff)
downloadgentoo-543cf8fe.tar.gz
gentoo-543cf8fe.tar.bz2
gentoo-543cf8fe.zip
sys-devel/lld: Stop building and installing split shared libs in 10+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index 2469a9bd7046..71f20ca05123 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -55,7 +55,7 @@ src_unpack() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=OFF
-DLLVM_INCLUDE_TESTS=$(usex test)
)
@@ -73,3 +73,8 @@ src_test() {
local -x LIT_PRESERVES_TMP=1
cmake-utils_src_make check-lld
}
+
+src_install() {
+ default
+ find "${D}" -name '*.a' -delete || die
+}