summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-30 05:51:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-30 06:26:57 +0200
commit544597bdad59dbae67437a3be5be686f9c82305b (patch)
tree0e38833c24f32366430f1a60937d53585b93ed77
parentdev-python/tox: Bump to 3.25.1 (diff)
downloadgentoo-544597bd.tar.gz
gentoo-544597bd.tar.bz2
gentoo-544597bd.zip
dev-python/vcrpy: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-4.2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 8bc3f60270bc..ce78bd7d0563 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-4.1.1.tar.gz 329508 BLAKE2B b6981150a8fd742301e0d7897d84855c741c97307bbb5c5751680f3d33d69d6333a18d714fcc14cb018f5dd6c02e840e1313136660c4459e2755d448fc0b07e9 SHA512 afa1904bff37bfd2d278ed49fa3982a357eb6bb113818b532044da0f11a9dd877cc152d7f0d81d88bdc0f870521b1241f6aecf959f668211904e3c6c7cea4ad8
+DIST vcrpy-4.2.0.gh.tar.gz 331096 BLAKE2B dccb9310da42c6f75d0d503cb64aa09876447098bff2ad6a1507a0e0907ce05a89d46ccc159e79f310e027fc8f3075b7474274ad39ca4778acbc6d2a8f633004 SHA512 61eeec585fc78be1ae6d4f9047123c9680611e436bb5980fb7c6b885e16b2ef9bd5ce921efff7e87a222b3662c7009dbf0a8df24cdb9849d09deb24957ba4889
diff --git a/dev-python/vcrpy/vcrpy-4.2.0.ebuild b/dev-python/vcrpy/vcrpy-4.2.0.ebuild
new file mode 100644
index 000000000000..8f48fb71765f
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-4.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests require Internet
+ tests/integration/test_aiohttp.py
+ tests/integration/test_boto.py
+ tests/integration/test_httplib2.py::test_effective_url
+ tests/integration/test_httpx.py
+ tests/integration/test_urllib2.py::test_effective_url
+ tests/integration/test_urllib3.py::test_redirects
+ tests/integration/test_wild.py::test_amazon_doctype
+ tests/integration/test_wild.py::test_flickr_should_respond_with_200
+ tests/unit/test_stubs.py::TestVCRConnection::testing_connect
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest
+}