summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:34:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:07 +0200
commit5469d28e186e7235088c89aa04f9a06510e931bf (patch)
tree0e07a0c161f371cb0691fd7246bb8bfe98273c80
parentdev-libs/jsoncpp: Port to cmake.eclass (diff)
downloadgentoo-5469d28e186e7235088c89aa04f9a06510e931bf.tar.gz
gentoo-5469d28e186e7235088c89aa04f9a06510e931bf.tar.bz2
gentoo-5469d28e186e7235088c89aa04f9a06510e931bf.zip
dev-libs/libdivsufsort: Remove live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
deleted file mode 100644
index d6c33d70a4c5..000000000000
--- a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGIT_REPO_URI="https://github.com/y-256/${PN}"
-inherit cmake-utils multilib toolchain-funcs git-r3
-
-DESCRIPTION="Suffix-sorting library (for BWT)"
-HOMEPAGE="https://github.com/y-256/libdivsufsort"
-SRC_URI=""
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="openmp"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # will appreciate saner approach, if there is any
- sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
- */CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON" "-DUSE_OPENMP=$(usex openmp)")
- cmake-utils_src_configure
-}